1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF install stuck on "Rebuilding...Core Master Data"

Discussion in 'Installation, Upgrade, and Import Support' started by Ryan Kent, Feb 24, 2011.

  1. Ryan Kent

    Ryan Kent Well-Known Member

    I am installing a clean install of XF RC2 on my local pc(yes 2 first, then I'll upgrade to 3...to mirror the process I used on my live server).

    I followed Brogan's guide for setting up XAMPP on my Windows XP machine, and all went well up to a point. Step 1 Welcome, Step 2 Verify Configuration went fine, and I am stuck on the third step Install. My browser says "Rebuilding...Core Master Data". It has been there for 10 minutes, so I pressed the Rebuild Caches button below it, and it is still stuck there after 10 minutes. I tried rebooting but the install process becomes stuck at the same place.

    The only note is the first time I began the install process I missed changing the permissions on the data and internal_data folders. I caught the mistake, unchecked "read-only" default setting, but the issue remains.
  2. Mike

    Mike XenForo Developer Staff Member

    Honestly, I'm not sure what would cause this. You may need to poke around the error log in XAMPP. That said, I know there are various people running/installing XF on XAMPP without any problem. The oddity you had with the requirements script suggests that there could be more low level issues.
  3. Ryan Kent

    Ryan Kent Well-Known Member

    I checked the XAMPP error logs...nothing. So I decided to try this on a second pc. I installed XAMPP, followed all the steps and am getting the exact same issue at the same spot. The only other additional piece of info is I tried the install with an IE browser on the 2nd pc. It had a pop-up message at the stop saying I was using "intranet" settings which were less secure, so I clicked on it, and the XF Error message "action_available_via_post_only" appeared.

    Edit: I turned on script debugging and see a msg - - - Unterminated string constant. jquery 1.4.4.min.js Code 0 URI http://localhost/community/js/jquery/jquery-1.4.4.min.js

    The install process is stuck at step 2b
  4. Mike

    Mike XenForo Developer Staff Member

    Well, that error may indicate that the files weren't extracted correctly or that the server isn't outputting files correctly. Being that this is on localhost, it's not really trivial for us to debug.
  5. Ryan Kent

    Ryan Kent Well-Known Member

    Just offering an update in case someone else follows in my footsteps.

    I was determined to not give up. I have tried using a full install of RC2 and RC3, so I am certain it is not an issue with the files. I have tried using two different pc's, so I am sure it's not a pc issue per se. I originally tried with XAMPP, and now I have tried using ZEND. When I try to install Zend I get stuck on an error message that says "Zend Server Community Edition failed to load required JavaScript Files". I tried the process with both FF and IE, the same result. I tried on two different pc's, same result.

    I uninstalled my old Java software on each pc, went to Sun site and updated to current version, rebooted, etc. and tried again. Same result. I searched Zend support site. Multiple others have reported the issue back in 2009, but no resolution was offered. It seems I cannot install a local version of XF as a test site. I'll explore other options.
  6. Douglas

    Douglas Member

    Java that you download from Sun and JavaScript have nothing to do with each other, so you can shift any attention away from that being the issue :)
  7. Decent60

    Decent60 Well-Known Member

    We had a similar experience to this with RC1 and several BETA. The problem was that our server was, well for a better term, over burdened with queries (not just from us, but others on the shared host). Our host isn't a VPS, so hard to determine what was the nature. If you are doing it local, kill all unnecessary processes and watch the memory usage. It could be that your XAMPP taxing your memory.
    For us, the solution was to try it at a different time of day, less usage on the server overall.

    Likewise, you could try installing XAMP Lite instead of the full version.
  8. Ryan Kent

    Ryan Kent Well-Known Member

    Thanks for sharing your experience. For me, this happened on 2 different pc's. Both pc's were freshly rebooted. There was not any programs running at all, other then the standard background processes. I even disabled my virus scanner. I am not sure of the cause, but it really can't be a load issue, but once again I really appreciate your feedback.
  9. Nasr

    Nasr Well-Known Member

    Try installing Wamp server. See if you get the same issue.

Share This Page