• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Xenforo to Xenforo import Bug

TsinJu

Well-known member
#1
While "Configure User Import" i checked
  • When email addresses are the same
  • When names are the same
  • Search for Gravatar when users do not have an avatar
i get this Error
Server Error
Argument 1 passed to XenForo_Importer_XenForo::_mergeUser() must be an array, string given, called in /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php on line 614 and defined

  1. XenForo_Application::handlePhpError() in XenForo/Importer/XenForo.php at line 626
  2. XenForo_Importer_XenForo->_mergeUser() in XenForo/Importer/XenForo.php at line 614
  3. XenForo_Importer_XenForo->_importOrMergeUser() in XenForo/Importer/XenForo.php at line 377
  4. XenForo_Importer_XenForo->stepUsers() in XenForo/Importer/Abstract.php at line 77
  5. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 183
  6. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 235
  7. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 178
  8. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 337
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /var/customers/webs/myfolder/xenresp/admin.php at line 13
Here´s a list of Errors, the Server Error Log created.
Error Info
ErrorException: Undefined index: banner_text - library/XenForo/Importer/XenForo.php:1943

Stack Trace
#0 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(1943): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/customers/...', 1943, Array)
#1 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(233): XenForo_Importer_XenForo->_quickAssembleData(Array, Array)
#2 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/Abstract.php(77): XenForo_Importer_XenForo->stepUserGroups(0, Array)
#3 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(183): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'userGroups', 0, Array)
#4 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(235): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'userGroups', 0, Array)
#5 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(178): XenForo_ControllerAdmin_Import->_startStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'userGroups', Array)
#6 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(337): XenForo_ControllerAdmin_Import->actionStartStep()
#7 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /var/customers/webs/myfolder/xenresp/admin.php(13): XenForo_FrontController->run()
#9 {main}

Request State
array(3) {
["url"] => string(54) "http://xenresp.forum.com/admin.php?import/start-step"
["_GET"] => array(1) {
["import/start-step"] => string(0) ""
}
["_POST"] => array(2) {
["step_userGroups"] => string(18) "Import User Groups"
["_xfToken"] => string(8) "********"
}
}

------------------------------------

Error Info
ErrorException: Undefined index: banner_css_class - library/XenForo/Importer/XenForo.php:1943

Stack Trace
#0 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(1943): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/customers/...', 1943, Array)
#1 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(233): XenForo_Importer_XenForo->_quickAssembleData(Array, Array)
#2 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/Abstract.php(77): XenForo_Importer_XenForo->stepUserGroups(0, Array)
#3 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(183): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'userGroups', 0, Array)
#4 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(235): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'userGroups', 0, Array)
#5 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(178): XenForo_ControllerAdmin_Import->_startStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'userGroups', Array)
#6 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(337): XenForo_ControllerAdmin_Import->actionStartStep()
#7 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /var/customers/webs/myfolder/xenresp/admin.php(13): XenForo_FrontController->run()
#9 {main}

Request State
array(3) {
["url"] => string(54) "http://xenresp.forum.com/admin.php?import/start-step"
["_GET"] => array(1) {
["import/start-step"] => string(0) ""
}
["_POST"] => array(2) {
["step_userGroups"] => string(18) "Import User Groups"
["_xfToken"] => string(8) "********"
}
}

------------------------------------

ErrorException: Argument 1 passed to XenForo_Importer_XenForo::_mergeUser() must be an array, string given, called in /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php on line 614 and defined - library/XenForo/Importer/XenForo.php:626

Stack Trace
#0 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(626): XenForo_Application::handlePhpError(4096, 'Argument 1 pass...', '/var/customers/...', 626, Array)
#1 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(614): XenForo_Importer_XenForo->_mergeUser('TsinJu', 1)
#2 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/XenForo.php(377): XenForo_Importer_XenForo->_importOrMergeUser(Array, Array)
#3 /var/customers/webs/myfolder/xenresp/library/XenForo/Importer/Abstract.php(77): XenForo_Importer_XenForo->stepUsers(0, Array)
#4 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(183): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'users', 0, Array)
#5 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(235): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'users', 0, Array)
#6 /var/customers/webs/myfolder/xenresp/library/XenForo/ControllerAdmin/Import.php(178): XenForo_ControllerAdmin_Import->_startStep(Object(XenForo_Importer_XenForo), Object(XenForo_ImportSession), 'users', Array)
#7 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(337): XenForo_ControllerAdmin_Import->actionStartStep()
#8 /var/customers/webs/myfolder/xenresp/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /var/customers/webs/myfolder/xenresp/admin.php(13): XenForo_FrontController->run()
#10 {main}

Request State
array(3) {
["url"] => string(54) "http://xenresp.forum.com/admin.php?import/start-step"
["_GET"] => array(1) {
["import/start-step"] => string(0) ""
}
["_POST"] => array(3) {
["options"] => array(4) {
["mergeEmail"] => string(1) "1"
["mergeName"] => string(1) "1"
["gravatar"] => string(1) "1"
["_dummy"] => string(1) "1"
}
["step"] => string(5) "users"
["_xfToken"] => string(8) "********"
}
}
There seems to be another Error with "Import Nodes".
After click it i get this Error
Error
  • Please enter a valid value.
  • Please enter a valid value.
  • Please enter a valid value.
I cant import any of my Nodes
 
Last edited:

Mike

XenForo developer
Staff member
#2
Some of your errors indicate that you're importing from XenForo 1.1 (I'd guess). The import only works against XenForo 1.2.
 

Mike

XenForo developer
Staff member
#3
I have fixed the first issue. You can workaround it by not selecting automatic merging by name. If you have the other issues when you're importing from XenForo 1.2, please post a new bug report - one report for each issue.