• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XenForo sites don't work on mobile device emulators

Steve F

Well-known member
#2
Get this in console of Chrome and FF

Code:
Chrome: Refused to display 'http://xenforo.com/community/' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'. 

FireFox: Load denied by X-Frame-Options: http://xenforo.com/community/ does not permit cross-origin framing.
 

Mike

XenForo developer
Staff member
#3
Framing the site is a potential (albeit obscure) security issue (clickjacking). You can generally just shrink your browser window.
 

rainmotorsports

Well-known member
#6
I always test on my actual device or a reduced browser window. The only way to be truly sure is to be on the platform with the browsers you want to test. Obviously its much easier to test resolution based problems with a desktop browser.

That second site doesn't even have correct resolutions for the devices it portrays making it more of a try out a random low res frame than anything. HTC One is a 1080P device is it not? I mean you have to account for text scaling etc not sure if thats what they are attemping.
 

Arty

Well-known member
#7
Those are not mobile device emulators, those are simple frames. Browser behaves like on desktop, not like on mobile devices. Both are completely pointless websites.

If you want real emulator install XCode. Its free. It has real emulator of iOS devices, not like those fake websites.