1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Xenforo Resource Manger - Unable to Rate/Review

Discussion in 'Resource Manager Support' started by Wren, Oct 30, 2013.

  1. Wren

    Wren New Member

    So I'm having a bit of an issue finding out what is wrong with my resource manager. I'm using version 1.0.2 and XF version 1.2. None of my guides can be rated or reviewed, I'm missing tabs that exist once you're inside the actual guide (similar to the RM on this site).

    I've looked on the site and googled, and couldn't find any documentation. That or it is really well hidden. Is there something obvious I'm missing? All permissions are set accordingly. Resources were renamed to Guides fyi.

    Thanks for the help.

    This image shows where expected tabs would be.
    A sample guide: http://forums.ffxivhorizon.com/resources/conjurer-hunting-log.10/

    test.jpg
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Use the Permissions Analyzer in Admin CP > Users > Permissions Analyzer.

    It's likely that you're perhaps a member of a usergroup that has the rate/review permissions set to "Never". That will override any permission that is set to No or Allow.

    Usually to prevent someone from doing something it is sufficient to set the permission to "No".
     
  3. Wren

    Wren New Member

    Checked, everything for every user group is set to allow/yes.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Have you made any changes to the code, or have you installed any add-ons which may be affecting this?

    I have just reviewed your resource. Which means this page should work: http://forums.ffxivhorizon.com/resources/conjurer-hunting-log.10/reviews

    But I get redirected back to the resource page. That would only happen if no reviews are found, yet clearly there is one.

    This is what makes me think either add-ons or some code changes you guys have made are causing it.

    So, try it with all other add-ons disabled. Then finally, re-upload all of the files for RM 1.0.2.
     
  5. Wren

    Wren New Member

    hmmm, interesting.
    Tried disabling plugins, even reinstalling the RM and still no luck.
    I had switched around a bunch of the phrases, would this have effected it? None of the actual templates were modified.

    Edit - thanks for all your help btw! :)
     
    Last edited: Oct 30, 2013
  6. Chris D

    Chris D XenForo Developer Staff Member

    I can't see how changing phrases would affect it.

    What process did you follow to reinstall the RM?

    Only last thing I can think of trying is upgrading to the RM 1.1.0 which was released as a release candidate today. It's pretty stable and seems to be bug free, and in use heavily here so it's quite safe to do so.

    But I still can't really rationalise why it is happening. I can't even think why upgrading the RM would fix it to be honest.
     
    Wren likes this.
  7. Wren

    Wren New Member

    FIXED!

    I completely uninstalled the RM 1.0.2 and deleted all associated files. And I reinstalled the 1.1 RC from scratch. I also recently moved domains, and just backed everything from the old domain up to the new one. So maybe that had something to do with it? Anyways, it works now so that is a relief.

    Thanks again Chris
     
    Chris D likes this.

Share This Page