1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't rate/review comments after most recent update to RM

Discussion in 'Resource Manager Support' started by ggace, Nov 15, 2013.

  1. ggace

    ggace Active Member

    Since the most recent update to 1.1.0, I have been unable to rate/review any resource. The resources are simply greyed out. I have attempted to reinstall the most recent update 3 times with no success. Due to the abundance of resources within the resource manager I am not not trying to delete & reinstall everything.

    I have checked the permissions and attempted to test on the default theme (no custom template edits made there). I have also disabled all addons with absolutely no success. This was working just fine in the beta versions as some resources were rated.

    Any help would be greatly appreciated.

  2. ggace

    ggace Active Member

    Sorry I managed to place this in the enhanced search support. Please move to resource manager support.
  3. Mike

    Mike XenForo Developer Staff Member

    What's greyed out? The only thing that might be is downloading, which isn't necessarily related to rating. (Though if you can't download a resource, then you can't rate it.) If that's it, that's what you need to focus on and sort out. Nothing changed since the beta as far as I'm aware.

    Have you specified any per resource category permissions? Have you checked analyze permissions to look at the download permission value?
  4. ggace

    ggace Active Member


    We do not have downloaded resources however, we have never allowed downloading yet we were once able to rate (seen in the second screenshot).

    The stars to rate a resource would be what I am referring too.


    Previously you could hover over the stars & they would change yellow thus allowing you too vote. I checked each "genre" or category permission. For a test I gave the "admins" 100% full access. I even did it by individual name to give ALL resource access but still unable to rate.

    Here is a quick screenshot of 5 resources that were all able to be rated. After October 25th (the release that was related to that time) I was not able to rate anything.
    some ratings.png
  5. Mike

    Mike XenForo Developer Staff Member

    Even if you don't have downloadable resources, you need to have the download permission -- the RM is first and foremost for managing files so it does base on that. For the user in question, does analyze permissions show download permissions?

    If you want to submit a ticket with ACP info (and a user that should be able to rate that can't), I can look into it.
    ggace likes this.
  6. ggace

    ggace Active Member

    Actually it was the "Can download" option in the usergroup. This was never actually changed by me but this was set to inherit which in turn proved your theory above.

    This fixed my problem. Thanks for the great support as always Mike!
  7. qz2

    qz2 Member

    I ran into this issue as well and had to change Administrator, Moderator and Registered user permissions to Allow on all Resource Permissions to get ratings and reviews to work, great add-on!
  8. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page