1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Xenforo Email Error

Discussion in 'Troubleshooting and Problems' started by Jacob Stretton, Oct 20, 2014.

  1. Jacob Stretton

    Jacob Stretton New Member

    Server Error Log
    Error Info
    Zend_Mail_Transport_Exception: Email to mwpkiller@gmail.com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
    Generated By: Mwpkiller97, Yesterday at 4:50 AM
    Stack Trace
    #0 /var/www/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /var/www/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /var/www/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /var/www/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
    #4 /var/www/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('mwpkiller@gmail...', 'Mwpkiller97')
    #5 /var/www/library/XenForo/ControllerPublic/AccountConfirmation.php(103): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
    #6 /var/www/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_AccountConfirmation->actionResend()
    #7 /var/www/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 /var/www/index.php(13): XenForo_FrontController->run()
    #9 {main}
    Request State
    array(3) {
    ["url"] => string(57) "http://minespud.com/index.php?account-confirmation/resend"
    ["_GET"] => array(1) {
    ["account-confirmation/resend"] => string(0) ""
    }
    ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(43) "/index.php?forums/glitches/&order=post_date"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Has this happened only once or is it constant?
     
  3. Jacob Stretton

    Jacob Stretton New Member

    When ever someone signs up i get this error
     
  4. Mike

    Mike XenForo Developer Staff Member

    That would generally indicate that the mail program isn't configured correctly (or PHP hasn't been configured to point to it). If this is a shared host, you'd need to contact them or use SMTP; if this is a VPS or dedicated server, you should install something like Postfix.
     
  5. OldCoals

    OldCoals Active Member

    I have started to get this error over the past couple of days, I will check with my host.
     

Share This Page