1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 XenForo/DataWriter.php Error

Discussion in 'Troubleshooting and Problems' started by Andy Black, Apr 30, 2014.

  1. Andy Black

    Andy Black New Member

    Hi,

    I'm new to Xenforo and recently had it installed for me.
    I presume it's the latest version of Xenforo (XF1.3) since I bought it last week.

    I was trying to change a password today, and did it incorrectly (the new passwords didn't match). I got an ugly popup with the error below though.

    Similarly, if I try and create a page but don't put the URL portion in, I get an error, and all that php messages.

    Is this normal behaviour, or does it indicate there's something wrong somewhere (I'm suspecting permissions since "save" is mentioned a few times below).

    Thanks,
    Andy

    ERROR THAT I GET IF I TRY AND CHANGE THE PASSWORD INCORRECTLY

    An exception occurred: Passwords did not match. Please enter the same password in both fields. in /home/MYDOMAIN/public_html/forum/library/XenForo/DataWriter.php on line 1345

    XenForo_DataWriter->_haveErrorsPreventSave() in XenForo/DataWriter.php at line 1387
    XenForo_DataWriter->save() in XenForo/ControllerPublic/Account.php at line 1076
    XenForo_ControllerPublic_Account->actionSecuritySave() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/streetsm/public_html/forum/index.php at line 13


    EDIT:
    The forum is in www.streetsmartppc.com/forum

    Originally it was in www.streetsmartppc.com, but I got it moved to the /forum folder.

    Maybe this was the cause of the problem?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Was it working fine before you moved the installation?
    If so, it could be related to the move.

    Try running the file health check in the ACP.
     
  3. Andy Black

    Andy Black New Member

    Maan, you guys respond so fast.

    I don't know whether it was fine before the installation was moved.
    I hadn't tried to do anything within the forum before the move.

    I ran ACP -> Tools -> File Health Check

    The result is:
    All 1,125 checked files are present and correct. :)


    So those errors are abnormal then?

    There's no content to speak of within my forum. Would it be easier for me to blow away my installation completely, and reinstall (you can tell I used to be in I.T. eh?).
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If there's no content, then a clean install is probably the simplest and quickest solution.

    Download a fresh .zip from your customer area and upload the files once more, to rule out any issues with corrupted or missing files.
     
  5. Mike

    Mike XenForo Developer Staff Member

    Something is wrong. I suspect it's a PHP-level conflict from an opcode cache. The reason is that this is an error that would normally simply be displayed back to you. The way the error is being presented is how a technical failure occurs, not a printable error like this. Effectively, the code being run is subtly different than the code that was written. We have seen this before with newer PHP versions and older opcode caches. If you're not running a VPS/dedicated server, unfortunately you wouldn't generally be able to change this directly, though the cache may be able to be disabled. You would need to contact your host for guidance though.
     
    Brogan likes this.
  6. Andy Black

    Andy Black New Member

    Thanks Brogan, Mike. I've forwarded your responses onto my hosting and will see what they say.

    "opcode caches" eh? I'm off to Google what they are now... :)

    A fresh installation might not help then, but we might have to do it just to rule it out.

    I'm worried that this shared hosting is not setup to run Xenforo now, even though that's why I went with them. We'll see...
     
  7. Andy Black

    Andy Black New Member

    The host support guys installed a fresh download of the Xenforo zip file it into a fresh subdirectory (www.streetsmartppc.com/forums).

    I'm still getting the verbose errors, so have asked them to check the opcode cache and PHP compatibility like Mike mentioned, or otherwise resolve the problem.

    I presume if we can't fix this, then I should move host or package with them?
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, if the host is unable to resolve the server-related issues, then moving hosts is probably the best option.
     
  9. Andy Black

    Andy Black New Member

    Fixed. Phew.

    The host support guys said this:

    "I'd never seen that error from XF before... Accounts can individually choose different cache types and I see yours had been set to eAccelerator when the correct setting was Xcache"

    I didn't make any changes to settings, but at least it's sorted now.

    You guys and the URLJet guys have been fantastic. I'm hoping to launch next week and this would have been a bit of a setback.

    Thanks very much.
    Andy
     
    Mike likes this.

Share This Page