1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XenForo and Internet Explorer

Discussion in 'General XenForo Discussion and Feedback' started by HWS, Nov 5, 2012.

  1. HWS

    HWS Well-Known Member

    More and more users are complaining that XenForo is hard to use with Internet Explorer. We even hear that users are not able to post if they use that browser.

    What are your experiences with XenForo and IE?

    Could it be that the very old jQuery version XenForo uses is the reason for that?
  2. Digital Doctor

    Digital Doctor Well-Known Member

    which IE ?
    what problems ?

    IE sucks for everything.
    Hoffi, Adam Howard and Chris D like this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    I've never had an issue with Internet Explorer 8, 9 or 10.

    You got any firmer details on IE version? OS version? Specific errors?
  4. James

    James Well-Known Member

    I've tested XF with IE (albeit 2 years ago) and it worked fine. It didn't look as good, naturally, but it functioned perfectly well.
  5. HWS

    HWS Well-Known Member

    No details, sorry. But it seems to happen very often. Especially people who access our forums from their workplace computer do complain. So i assume the IE version is rather old and/or security settings are tight.
  6. Digital Doctor

    Digital Doctor Well-Known Member

    Isn't there a site where you can browse your own site with virtual browsers ?
    try that.
    Did u try IE 8,9,10 yourself ?
  7. Digital Doctor

    Digital Doctor Well-Known Member

    Actually that could be an interesting experience for an admin.
    Use IE on your site for a week.
  8. Chris D

    Chris D XenForo Developer Staff Member

    Not a lot we can do without more details.

    Obviously there's a potential problem if it's IE8, 9 or 10. If that is the case it should be looked into.

    If it's IE6 or 7, though, then... well, not really a lot we can do. The versions of Firefox and Chrome that were out during those two versions of IE don't work too great either.

    It's not reasonable to expect a modern piece of software to function correctly in a 6 to 11 year old browser.
  9. HWS

    HWS Well-Known Member

    So you all can at least confirm that this problem does not have anything to do with jQuery version?
    Because the problems reported all have to do with Ajax features.
  10. Digital Doctor

    Digital Doctor Well-Known Member

    Like ?
  11. Chris D

    Chris D XenForo Developer Staff Member

    If anything, the old version of jQuery will make it MORE compatible with older browsers.

    But I can confirm that in IE8, 9 and 10, XenForo functions perfectly.
  12. Brandon Sheley

    Brandon Sheley Well-Known Member

    Find out what version of IE they are using and if they have anything blocked eg.. javascript..
    It's working fine for me and we have our systems locked down pretty tight.
    Chris D likes this.
  13. HWS

    HWS Well-Known Member

    IE version seems to be 8.

    The most thing complained about is not being able to post. They write long postings and want to send it ... and nothing happens. Usually an Ajax function inserts the new post directly into the DOM.
  14. James

    James Well-Known Member

    That sounds more like a server issue than a browser issue.
    Adam Howard likes this.
  15. HWS

    HWS Well-Known Member

    If it is a server issue (could certainly be), it only comes to an effect in combination with Internet Explorer. No complaints by users of other browsers.
  16. Chris D

    Chris D XenForo Developer Staff Member

    Could we get a URL to your site, HWS? So we can test with our browsers and our IE?
    Claiver likes this.
  17. Adam Howard

    Adam Howard Well-Known Member

    Internet Explorer 10 is thus far the first IE which seems to load things just as well as Firefox or Chrome.... So far.... Who knows what update or when that could change.

    Internet Explorer 9 was OK, but often people needed to switch between compatibility modes. This was annoying and confusing for the non tech aware individual (typical end user).

    Hated everything before IE9 (Technically, hated IE9 too, but could "live with it").
  18. mike os

    mike os Active Member

    i use ie9 as my main browser... because of the way it behaves.... the rest will skip coding errors that ie will not and too many people stil use ie to ignore it

    no problems i have noted with xf
  19. RickM

    RickM Well-Known Member

    Cant really take anyone seriously who uses IE - explain to your members that its likely a browser issue, due to most versions of IE being out of date. If they are on Windows XP but dont want to use the much superior webkit based browsers, ask them to install chromeframe.

    If people still refuse then screw them. Sorry but IE is a plague on the internet.
  20. James

    James Well-Known Member

    A simple HTML notice will suffice:
    <!--[if IE]>
    <p>Upgrade to a more modern browser</p>
    Chris D likes this.

Share This Page