• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XenForo and Internet Explorer

HWS

Well-known member
#1
More and more users are complaining that XenForo is hard to use with Internet Explorer. We even hear that users are not able to post if they use that browser.

What are your experiences with XenForo and IE?

Could it be that the very old jQuery version XenForo uses is the reason for that?
 

Chris D

XenForo developer
Staff member
#3
I've never had an issue with Internet Explorer 8, 9 or 10.

You got any firmer details on IE version? OS version? Specific errors?
 

James

Well-known member
#4
I've tested XF with IE (albeit 2 years ago) and it worked fine. It didn't look as good, naturally, but it functioned perfectly well.
 

HWS

Well-known member
#5
No details, sorry. But it seems to happen very often. Especially people who access our forums from their workplace computer do complain. So i assume the IE version is rather old and/or security settings are tight.
 

Chris D

XenForo developer
Staff member
#8
No details, sorry. But it seems to happen very often. Especially people who access our forums from their workplace computer do complain. So i assume the IE version is rather old and/or security settings are tight.
Not a lot we can do without more details.

Obviously there's a potential problem if it's IE8, 9 or 10. If that is the case it should be looked into.

If it's IE6 or 7, though, then... well, not really a lot we can do. The versions of Firefox and Chrome that were out during those two versions of IE don't work too great either.

It's not reasonable to expect a modern piece of software to function correctly in a 6 to 11 year old browser.
 

HWS

Well-known member
#9
So you all can at least confirm that this problem does not have anything to do with jQuery version?
Because the problems reported all have to do with Ajax features.
 

Chris D

XenForo developer
Staff member
#11
So you all can at least confirm that this problem does not have anything to do with jQuery version?
Because the problems reported all have to do with Ajax features.
If anything, the old version of jQuery will make it MORE compatible with older browsers.

But I can confirm that in IE8, 9 and 10, XenForo functions perfectly.
 

Brandon Sheley

Well-known member
#12
Find out what version of IE they are using and if they have anything blocked eg.. javascript..
It's working fine for me and we have our systems locked down pretty tight.
 

HWS

Well-known member
#13
IE version seems to be 8.

The most thing complained about is not being able to post. They write long postings and want to send it ... and nothing happens. Usually an Ajax function inserts the new post directly into the DOM.
 

Adam Howard

Well-known member
#17
Internet Explorer 10 is thus far the first IE which seems to load things just as well as Firefox or Chrome.... So far.... Who knows what update or when that could change.

Internet Explorer 9 was OK, but often people needed to switch between compatibility modes. This was annoying and confusing for the non tech aware individual (typical end user).

Hated everything before IE9 (Technically, hated IE9 too, but could "live with it").
 

mike os

Active member
#18
i use ie9 as my main browser... because of the way it behaves.... the rest will skip coding errors that ie will not and too many people stil use ie to ignore it

no problems i have noted with xf
 

RickM

Well-known member
#19
Cant really take anyone seriously who uses IE - explain to your members that its likely a browser issue, due to most versions of IE being out of date. If they are on Windows XP but dont want to use the much superior webkit based browsers, ask them to install chromeframe.

If people still refuse then screw them. Sorry but IE is a plague on the internet.