XF 1.2 xen stopped working

server upgraded cpanel/php/mysql and now only get this error on page

An exception occurred: Mysqli statement execute error : Incorrect arguments to mysqld_stmt_execute in /home/rhino/public_html/connect/library/Zend/Db/Statement/Mysqli.php on line 214

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 734
  4. Zend_Db_Adapter_Abstract->fetchAll() in EWRporta/Block/RecentNews.php at line 38
  5. EWRporta_Block_RecentNews->getModule() in EWRporta/Model/Blocks.php at line 116
  6. EWRporta_Model_Blocks->getBlockParams() in EWRporta/ViewPublic/Custom.php at line 71
  7. EWRporta_ViewPublic_Custom->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 227
  8. XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
  9. XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 572
  10. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  11. XenForo_FrontController->run() in /home/rhino/public_html/connect/index.php at line 13
Post in the XenPorta thread for support with that error.
I didn't see what seemed an official xenporta thread? which were you referring to?

also is there a way to go into DB and disable xenporta so i can get the forum itself operational?

To note it did work fine prior to upgrading


Well-known member
Edit your config.php file, and add in:

$config['enableListeners'] = false;

That will disable all add-ons, at which point, go into the ACP and disable XenPorta.