• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 XAMPP to IIS7

#1
So I recently came across the money to build a nice server with Windows 7 on it. I used to use an old rackmount server i had around with win7 as well. I wanted to upgrade from xampp to iis as I am getting into webdesign more and hosting. The only problem is I can't get my XF installation to go. I have the domain www.divinedynasty.net/ pointing to my public ip and it works as usual. I really just need a guide for migrating all my content over to my new server. I did export the whole database and copied all the files in my xf installation dir. Every time I try to goto the homepage I get redirected to http://www.divinedynasty.net/forum/index.php?portal/portal/ which I presume is a rewrite error. Any ideas how to do fix this?

I do know this XAMPP = htaccess and IIS = web.config
 

Jake Bunce

XenForo moderator
Staff member
#2
There is a javascript redirect in place:

Code:
<head>
<script language="javascript"><!--
location.replace("http://www.divinedynasty.net/forum/index.php?portal/portal/")
//-->
</script>
</head>
You need to find that redirect. Maybe it's in a different index file in the forum directory?
 
#3
I found it and removed it. there was a reason it was there because I used WP before and had the forums as a subfolder not a domain. Then when I dropped WP I left it in so that their bookmarks work.

Now I am getting a 500 internal error... looking into it
 
#4
ok got it. I just deleted everything and uploaded my files, then I created an SQL query for Navicat. I found out that I had to do SET GLOBAL max_allowed_packet=536870912; because my file was over 52mb. Thanks for the help. And if you care, what do you think of my design work?
www.divinedynasty.net/