1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XAMPP & NOD32 Confliction?

Discussion in 'Off Topic' started by James, Feb 17, 2011.

  1. James

    James Well-Known Member

    I've just installed the latest XAMPP (1.7.4 - previously used 1.7.3) and now the apache server won't start.

    I did netstat -anobv and found that the process ekrn.exe is using port 80 (xx.xxx.xxx.xxx:80). The problem I have is that it is a mandatory service that cannot be stopped.

    I tried disabling all protection on my anti-virus but apache still doesn't want to start.

    Is there a resolution to this that anyone is aware of?
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Enigma

    Enigma Well-Known Member

    There is most likely a setting in ESET NOD32 to tell it not to camp out on port 80. For the Skype conflict, just tell it not to use port 80 in Tools => Options => Advanced => Connection => Use port 80 and 443 as alternatives for incoming connections.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Changing ports in Skype didn't work for me.
    I had to uninstall it, install XAMPP, then reinstall Skype.

    I never found a way around IIS though, that did require changing the port for XAMPP.
  5. Enigma

    Enigma Well-Known Member

    No need to change Skype's port. Unchecking "Use port 80..." and maybe restarting Skype/the box should do it. Works for me anyway.
  6. bambua

    bambua Well-Known Member

    It depends on the version of IIS, but for all of them you can set the port bindings for the Default Web Site and as long as you do an iisreset after the change it will free up the port binding.
  7. James

    James Well-Known Member

    Changing the ports in the 2 areas in the httpd.conf didn't work - xampp still boots apache on 80.

    I haven't got Skype running but it doesn't use port 80 anyway.
  8. James

    James Well-Known Member

    OK I've managed to disable port 80 being used (disabling nod32's http checking).
  9. James

    James Well-Known Member

    But still Apache isn't working, even after a restart...

    perhaps reinstalling it.

Share This Page