1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Widget for [8wayRun.Com] XenMedio (Media) Add-on on WidgetFramework 1

Put a RecentMedia Widget on WidgetFramework for [8wayRun.Com] XenMedio (Media) Add-on

  1. lms

    lms Well-Known Member

  2. kkm323

    kkm323 Well-Known Member

    Thanks a lot for providing this resource! (y)
    I will be using it soon
     
  3. intradox

    intradox Well-Known Member

    I may be overlooking something but how would I get this recent widget to only show 4 or 2 videos. Currently it shows all the videos in XenMedio.
     
  4. lms

    lms Well-Known Member

    How many videos have you configured in media recent count (ACP->Home->Options->[8wayRun.Com] XenMedio (Media) ->Number of recent Media)?

    Salud2
     
    intradox likes this.
  5. intradox

    intradox Well-Known Member

    Ah didn't realize it was tied to that. Thanks for the clarification.
     
  6. nando99

    nando99 Member

    Where do I "Edit and replace ALL text of EWRblock_RecentMedia with supplied code below"?

    thanks in advance
     
  7. lms

    lms Well-Known Member

    EWRblock_MediaRecent template. Sorry. I fixed the error.

    Salud2
     
  8. nando99

    nando99 Member

    I dont seem to have that template :confused:

    I have all the neccesary mods installed, removed everything from the XenFacil's WidgetFramework Renderers and just added EWRmedio_MediaRecentWidget and now I'm lost :(

    Any help is appreciated
     
  9. lms

    lms Well-Known Member

    From XenPortal, import a block named MediaRecent.xml (on library/EWRporta/XML_Addons). It's not necesary toshow in portal. Only import it.

    Salud2
     
  10. nando99

    nando99 Member

    So I need to have the portal installed as well? I thought you only need [8wayRun.Com] XenMedio (Media), [bd] Widget Framework and XenFacil's WidgetFramework Renderers...
     
  11. lms

    lms Well-Known Member

    Yes, the widget is a portal widget.

    Create a template named EWRblock_MediaRecent with the content of resource description and save changes.

    CREATE EWRblock_MediaRecent template with supplied code below

    Code:
    <xen:require css="EWRmedio.css" />
    <xen:require css="member_list.css" />
    
    <div class="section">
        <div class="secondaryContent mediaSmall" id="mediaRecent">
            <h3><a href="{xen:link media}">{xen:phrase recent_media}</a></h3>
    
            <xen:if hascontent="true">
            <ul>
                <xen:contentcheck>
                <xen:foreach loop="$MediaRecent" value="$media">
                    <li>
                        <div class="mediaContent">
                            <div class="image">
    
                                <xen:if is="{$media.service_media} == 'gallery'">
                                    <div class="overlays overBtmL"><b>{xen:phrase x_images, 'count={$media.media_duration}'}</b></div>
                                <xen:else />
                                    <div class="overlays overBtmR"><b><xen:if is="{$media.media_hours}">{$media.media_hours}:</xen:if>{$media.media_minutes}:{$media.media_seconds}</b></div>
                                </xen:if>
    
                                <a href="{xen:link 'full:media', $media}"><img src="{xen:if {xen:helper medio, $media}, '{xen:helper medio, $media}', '/data/media/{$media.media_id}.jpg'}" {xen:if {xen:helper medio, $media}, '', 'style="width:110px; height:62px;"'} border="0" alt="{$media.media_title}" /></a>
                            </div>
                            <div class="title">
                                <a href="{xen:link 'full:media', $media}">{$media.media_title}</a>
                            </div>
                        </div>
                    </li>
                </xen:foreach>
                </xen:contentcheck>
            </ul>
            </xen:if>
    
            <xen:if is="{$option.search}">
            <div class="findMember">
                <form action="{xen:link 'search/search'}" method="post" class="AutoValidator" data-optInOut="optIn" data-redirect="true">
                    <input type="search" name="keywords" class="textCtrl" placeholder="{xen:phrase search_media}..." results="0" title="{xen:phrase enter_your_search_and_hit_enter}" id="searchBar_keywords" value="{$search.keywords}" />
                    <input type="hidden" name="type" value="media" />
                    <input type="hidden" name="_xfToken" value="{$visitor.csrf_token_page}" />
                </form>
            </div>
            </xen:if>
        </div>
    </div>
    Salud2
     
    Last edited: Nov 23, 2013
    nando99 likes this.
  12. nando99

    nando99 Member

    I'm sorry, I'm confused again. So do I need to install the portal or do I just create the template? Because I created the template and added the widget but nothing shows...

    If it's easier, post in spanish I should be able to read it ;)
     
  13. lms

    lms Well-Known Member

    Si la plantilla está creada y tienes algún vídeo para mostrar, debieras verlo en widget framawork.
    If it's created the template and you have any media to show, would shown on widget framework.

    Solo es necesario crear esta plantilla (cuando está instalado XenPortal y se instala el módulo, se obtiene esta plantilla).
    It's necessary only create this template (when both XenPortal, module are installed, you get this template).

    ¿Cual es la dirección de tu foro? What is the web address of your forum?

    Salud2
     
    nando99 likes this.
  14. nando99

    nando99 Member

  15. lms

    lms Well-Known Member

    En la imagen tiene configurado el widget en la posición 0. Si está el widget Clear Sidebar después, RecentMedia no se verá.
    In the image, you have set widget in position 0. If Clear Sidebar widget is after them, RecentMedia Widget will not shown.

    Estoy tardando en recibir el email de confirmación.
    I'm slow to receive the confirmation email.

    Salud2
     
    nando99 likes this.
  16. nando99

    nando99 Member

    Not sure why you wouldnt receive the email confirm, but I will look into it... I activated your account.

    I changed the display position to 2 and still dont see it :(
     
  17. nando99

    nando99 Member

    i also made you admin... thanks man!
     
  18. lms

    lms Well-Known Member

    Ya lo tienes funcionando - You got it working

    55.png

    Salud2
     
    nando99 likes this.
  19. nando99

    nando99 Member

    it didnt work for me... you fixed it? now it works! weird lol thanks tho...
     
  20. lms

    lms Well-Known Member

    I solved it. I left it running.

    Work now?

    Salud2
     
    caoanh204 and nando99 like this.

Share This Page