1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why does XenForo auto-complete "@File"

Discussion in 'General XenForo Discussion and Feedback' started by buffy, Sep 16, 2013.

  1. buffy

    buffy Member

    While composing here, if I type "@File" a little pop-up appears touting "Filetrip". If I click it, or just press <Enter>, my text is automatically completed to "@Filetrip". On another site which uses XenForo, it's "@FileViewer". What's up with that?
     
  2. Rigel Kentaurus

    Rigel Kentaurus Well-Known Member

  3. buffy

    buffy Member

    Can it be turned off by a XenForo-using site's admin?

    And, there's a new editor for composing ... right? Inserted <code> blocks do not default to a monospaced font as once was the case. Can the admin change that?
     
  4. AndyB

    AndyB Well-Known Member

  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    The auto complete does nothing more than convert to a user BB code and links to a profile.
     
  6. buffy

    buffy Member

    I frequent a site that uses XenForo where I, and others, often post code. In the particular language, tokens beginning with "@" are common and significant. I have to jump through hoops to type "do x in @file<Enter>" without winding up with someone's username. It's just a pain in the ...
     
  7. Jeremy

    Jeremy XenForo Moderator Staff Member

    Add a space.
     
  8. buffy

    buffy Member

    Too much work ... but more a matter of principle; I don't like what I type being changed.
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Set your preferences to disable the RTE editor and nothing will change.
     
  10. buffy

    buffy Member

    I like the editor but I'll try it.
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    Styling is mostly CSS
     
    Amaury likes this.
  12. buffy

    buffy Member

    Can't live without the ability to insert code blocks.
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you are inserting code blocks, it doesn't attempt to auto complete.
     
  14. buffy

    buffy Member

    I usually just type the code and /code tags. It's quicker. So I'll try it ... here goes ...
    Code:
    some code
     
  15. cellarius

    cellarius Active Member

    Just ignore the popup and keep on typing normally whatever it is you want to type. Nothing gets changed automatically for me. It's just a list of options you could pick from if you wanted.
     

Share This Page