This is why I am asking. I got that warning when installing the beta. When I asked my host about upgrading he said he could but to make sure all my sites are compatible with PHP 5.4 and I want to make sure that 1.2.4 works on 5.4 or 5.5 before telling him to go ahead with the upgrade.
I think quite a lot of people are stuck on older versions of PHP (mainly due to shared hosting environments and hosts not bothering to upgrade), which is a shame, really... because there's many improvements made in each version.
I tend to advise people to have at least 5.4.24 (old stable) – 5.5.8 (current stable) installed.
My point was that saying that "xenforo works with PHP5.5" should probably be given the caveat that not necessarily all addons do so if there's a specific addon requirement they'll need to check that separately.