• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

What version of PHP should i be on?

#1
I'm on PHP 5.2 and talked to my host about upgrading.

I'm on Xenforo 1.2.4 and confused as to whether it will work on PHP 5.4 or 5.5.

Thanks.
 

Brogan

XenForo moderator
Staff member
#4
When you upgrade to 1.3 you will see the following warning:
The following warnings were detected when verifying that your server can run XenForo:

Your server is running an outdated and unsupported version of PHP (5.3.1). If possible, you should upgrade to PHP 5.4 or 5.5.

These may affect the proper execution of XenForo at times and should be ideally be resolved. "

Anything less than 5.3.3 will trigger that.

XenForo in general requires a minimum version of 5.2.4.
 
#5
When you upgrade to 1.3 you will see the following warning:



Anything less than 5.3.3 will trigger that.

XenForo in general requires a minimum version of 5.2.4.
This is why I am asking. I got that warning when installing the beta. When I asked my host about upgrading he said he could but to make sure all my sites are compatible with PHP 5.4 and I want to make sure that 1.2.4 works on 5.4 or 5.5 before telling him to go ahead with the upgrade.
 

Brogan

XenForo moderator
Staff member
#6
XenForo works with PHP 5.4 and 5.5.

I currently run XenForo 1.0.4, 1.1.5, 1.2.4, and 1.3.0 on PHP 5.5.6.
 
#9
Did the upgrade and my forum seems quicker and more responsive. Not sure if it's one of those in your head type things but I'm happy.

Thank you all for the input.
 

Null

Well-known member
#10
I personally run on PHP 5.5.8 (current stable).

I think quite a lot of people are stuck on older versions of PHP (mainly due to shared hosting environments and hosts not bothering to upgrade), which is a shame, really... because there's many improvements made in each version.

I tend to advise people to have at least 5.4.24 (old stable) – 5.5.8 (current stable) installed.
 

RobParker

Well-known member
#19
I wouldn't know.
You will have to ask the developer of each one.
My point was that saying that "xenforo works with PHP5.5" should probably be given the caveat that not necessarily all addons do so if there's a specific addon requirement they'll need to check that separately.