1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

what is the "Register-page URL" when running Forum in 2 languages

Discussion in 'Troubleshooting and Problems' started by erich37, Nov 26, 2010.

  1. erich37

    erich37 Well-Known Member

    I am running a Forum in 2 languages and would like to make a Link-Forum redirecting to the "Register"-page, but to the Register-page for each language.

    So I am trying to figure out the link for each of the 2 register-pages specific for each of the 2 languages.

    I have tried the following, but it does not work:

    domain.com/misc/language_id=2&redirect=/register

    domain.com/misc/language?language_id=2&redirect=/register

    domain.com/register?language_id=2
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The problem is that language_id URLs require a security token, and there does not appear to be a way to use security tokens in link forums.

    This will require some custom code to implement. You can post a request in this forum.
     
  3. erich37

    erich37 Well-Known Member

    Thanks Jake for your help.
     
  4. erich37

    erich37 Well-Known Member

  5. ragtek

    ragtek Guest

  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You know what. I was thinking about something similar but then I realized something... the language + register link will be for guests, right? The security token isn't required for guests, only for logged in users. That means the link forum should work.

    Use a link like this for the link forum:

    Code:
    index.php?misc/language/&language_id=2&redirect=index.php%3fregister
    
    Change the language_id appropriately. I tested this myself and it works for guests.

    The link doesn't use proper xen:link syntax, but I think this is the best you can do with a link forum.
     
    Thomas, erich37 and Brogan like this.
  7. erich37

    erich37 Well-Known Member

    Hi Jake,

    many thanks for this. It works fine when not being logged-in.

    But when being logged-in and clicking onto the Link-Forum, this gives a strange Error-message, well at least this Error-message does not look good for the user.
    Is there a way to change the text of this Error-message to something like "You are already a registered member" ?

    Security error occurred. Please press back, refresh the page, and try again.
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Rather than change the error message I recommend just hiding those link forums for everyone but guests. Enable this option for those forums:

    Admin CP -> Users -> Permissions -> Node Permissions -> [select a forum] -> Private node

    Then explicitly allow access to those forums for the Unregistered group.
     
    erich37 likes this.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    You could just set the view permissions to that node to Revoke for registered users.

    That way they won't see the link forum when logged in.

    Damnit! Too late :D
     
    erich37 and Jake Bunce like this.
  10. erich37

    erich37 Well-Known Member

    Jake, you are a GENIOUS !!!!

    Thanks a lot guys !
     
  11. erich37

    erich37 Well-Known Member

    ooops....... how do I explicitly allow access to those forums for the Unregistered group ?

    I went to:
    Admin CP -> Users -> Permissions -> Node Permissions -> [select a forum] ->

    and then checked the checkbox for "Private Node".
    Then I clicked onto Unregistered/Unconfirmed and see a huge list with permissions.

    In this colorful list I see "View Node" and then I clicked onto "Allow" (instead of "Inherit").

    The trouble is this does not work, saying even registered users see this Link-Forum.

    What am I doing wrong at the permissions stuff ?

    Appreciate your further help.
     
  12. erich37

    erich37 Well-Known Member

    oh, I guess I should not check the "Private" checkbox.......
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Once a node is Private, you must explicitly allow access to it (and all other nodes which are children) either via user group or user permissions.

    The other option is as I posted above, to Revoke the View permission for the registered user group for those nodes.

    For example, I have a "Welcome to the site" page at the top of my form home node list.
    The "View" permission is Revoked for Registered Users though so they never see it once logged in, only guests do.
     
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Enable the Private forum option:

    Admin CP -> Users -> Permissions -> Node Permissions -> [select a forum] -> Private node

    Screen shot 2010-11-27 at 3.24.29 PM.png

    Then allow access for guests:

    Admin CP -> Users -> Permissions -> Node Permissions -> [select a forum] -> Unregistered / Unconfirmed

    Screen shot 2010-11-27 at 3.29.54 PM.png

    Then click update below:

    Screen shot 2010-11-27 at 3.28.00 PM.png
     
  15. erich37

    erich37 Well-Known Member

    this time, Brogans version works perfect.
    Jake, your version does not work for me......
     

Share This Page