1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Weird home screen

Discussion in 'Styling and Customization Questions' started by The Observer, Sep 20, 2014.

  1. The Observer

    The Observer Member

    I was fiddling with some basic style settings and all of a sudden I have this:

    home.png

    Those white outlined black boxes shouldn't be black, they should be a shade of blue. What did I change to cause this? I can't for the life of me figure it out...

    Also, I managed to get the search bar to be darker than the default white but how do I change the text portion of it so it is useable?
     
  2. Isil`Zha

    Isil`Zha Active Member

    That whole sidebar seems to be overridden by something, suddenly... if I try to edit Building Blocks --> Secondary Content, it's just ignoring it now.

    It should be noted we also just upgraded from 1.1 to 1.4 last night, and while it was initially fine, the sidebar suddenly went black. There's nothing in extra.css for it, and the sidebar.css is identical to how it was before. We have a test site that has our forum right after the update, and the style still works just fine over there, but I can't find any differences in the Style settings. This is how the sidebar should look:

    [​IMG]

    We've been trying to fix various style issues like the notice background/text and suddenly the sidebar changed looks with no one touching it (at least not intentionally.)
     
  3. Isil`Zha

    Isil`Zha Active Member

    So I imported the working one from the test site into the live site with no parent... and it ended up the same without me touching it. o_O
     
  4. Steve F

    Steve F Well-Known Member

    This is being called in the CSS for the sidebar

    Code:
    .sidebar .primaryContent, .sidebar .secondaryContent
    
    That is not default, so I suggest searching the templates for that above. It is applying a black background. I don't see how both styles would display the same thing unless you have applied a Template Modification.
     
  5. Isil`Zha

    Isil`Zha Active Member

    hmm, I just did a search and this doesn't appear in any of the sidebar templates.
     
  6. Steve F

    Steve F Well-Known Member

    What I find odd, it seems all the styles are picking up the CSS for the style flexile you have installed. Are you sure the styles are not set as a child to flexile?
     
  7. Isil`Zha

    Isil`Zha Active Member

    Yes, I specifically imported it to have no parent style:

    [​IMG]

    The Spacebattles.comImport is what I pulled over from the test site and it has all the same issues.
     
  8. Steve F

    Steve F Well-Known Member

    Yea something has went haywire, all the styles are calling that CSS which is specifically on flexile sidebar styling. Almost seems flexile was imported in the default style, or something on your test site.

    Edit: It seems someone overwrote a style with flexile as the footer is picking up on flexile if you notice the Audentio copyright.
     
  9. Isil`Zha

    Isil`Zha Active Member

    It seems to be the other way around - the test site works as expected, it's the live site behaving oddly. I think I have an idea on what may have happened. @Xon mentioned he was importing the new Flexile to be compatible with 1.4.. I wonder if something when awry there.
     
  10. Steve F

    Steve F Well-Known Member

    What does the actual "Default Style" look like? I can't select it but admins can.
     
  11. Isil`Zha

    Isil`Zha Active Member

    [​IMG]

    ...and the footer has the Audentio on this and the Xenforo default. So it seems the master style is overriding on several elements?
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    If you suspect the master style has been edited, navigate to the install path and rebuild the master data.
     
    Xon, Isil`Zha and Steve F like this.
  13. Isil`Zha

    Isil`Zha Active Member

    Thanks for the help guys.
     
  14. Xon

    Xon Well-Known Member

    That fixed it.
     
    The Observer likes this.
  15. The Observer

    The Observer Member

    Any feedback on this portion?

    I can't for the life of me find that setting...
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    You have search disabled for guests so I can't see the problem, nor inspect the code.
     
  17. The Observer

    The Observer Member

    Sorry about that, should be good now.
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

    I'm not sure which bit you're referring to, but try this in EXTRA.css:

    Code:
    #QuickSearch
    {
        color: white;
    }
    Obviously adjust the colour to suit.
     
  19. The Observer

    The Observer Member

    I had:

    Code:
    #QuickSearch
    {
        background-color: #191f2d !important;
        color: white !important;
    }
    But when I separated into its own block like you have it works fine. Weird...
     

Share This Page