• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Weird Errog Log Entry

Rambro

Well-known member
#1
Everything was going fine and then my site went dead. Its back up now, but I've got these 5 lines in my cPanel error log. Any idea what this is:

2013-04-06 02:39:51.589 [INFO] [67.171.33.221:2513-1#APVH_domain] File not found [/home/domain/public_html/404.shtml]
2013-04-06 02:39:50.846 [NOTICE] [/home/domain/public_html/forum/.htaccess:11] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
2013-04-06 02:39:50.846 [NOTICE] [/home/domain/public_html/forum/.htaccess:10] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
2013-04-06 02:39:50.846 [NOTICE] [/home/domain/public_html/forum/.htaccess:9] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
2013-04-06 02:39:50.846 [NOTICE] [/home/domain/public_html/forum/.htaccess:8] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.

Nothing in my ACP Server Log. It might have to do with my FTP program. It was having problems connecting and was constantly trying to connect and then failing. Just throwing it out there. Any help would be greatly appreciated.
 

Jake Bunce

XenForo moderator
Staff member
#2
It doesn't like the default error docs. Just remove these lines from your XF .htaccess file:

Code:
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
This wouldn't take down your site though. Contact your host about that.
 

Rambro

Well-known member
#3
Maybe it was just a temporary thing. Site seems to be fine. But the log added a few more errors:

2013-04-06 09:31:32.365 [INFO] [24.127.195.167:62447-1#APVH_wdwv.net] File not found [/home/domain/public_html/404.shtml]
2013-04-06 09:31:32.365 [INFO] [24.127.195.167:62447-1#APVH_wdwv.net] File not found [/home/domain/public_html/forum/styles/black_responsive_purple/xenforo/gradients/white_50_25.png]
2013-04-06 09:31:12.125 [INFO] [24.127.195.167:62371-2#APVH_wdwv.net] File not found [/home/domain/public_html/404.shtml]
2013-04-06 09:31:11.929 [INFO] [24.127.195.167:62371-1#APVH_wdwv.net] File not found [/home/domain/public_html/404.shtml]

Also, and this is weird - I cannot seem to find my .htaccess file... A cPanel search comes up with this, but for the life of me, I CANNOT find any of these files:


/public_html/.htaccess

/public_html/forum/.htaccess

/public_html/forum/install/templates/.htaccess

/public_html/forum/install/data/.htaccess

/public_html/forum/internal_data/.htaccess

/public_html/forum/library/.htaccess
 

MattW

Well-known member
#4
You can't link images from inside cpanel

How are you looking for them? Files starting with a . are usually hidden in most FTP clients unless you check an option to show hidden files.
 

Rambro

Well-known member
#5
You can't link images from inside cpanel

How are you looking for them? Files starting with a . are usually hidden in most FTP clients unless you check an option to show hidden files.
Wasn't trying to link them, it was just a copy paste of the popup search box for .htaccess. For some reason I couldn't see it in cPanel. Still can't, actually.

In my public_html/forum directory, this is what my .htaccess file has:

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>

So just knock out the 4 Error lines?
 

MattW

Well-known member
#6
No, that is cpanel trying to use it's own 404.shtml file. You need to manually create one inside cpanel to stop that error message.

cpanel_advanced.PNG
cpanel_404.PNG
 

MattW

Well-known member
#8
Sorry, you lost me there. I need to manually create a .htaccess in cPanel? With what in it?
No, you need to create a 404 error page to serve. In the pictures I posted, click Error pages, then click the 404 (not found) one. You can then make an error page inside cpanel, and it will stop those error messages about 404.shtml not found
 

Rambro

Well-known member
#9
I fixed some code in a template of mine (the theme error above) and when I checked the error log, everything's gone. Does that mean I don't have to bother?

If I do, would you mind walking me through how to configure the 404 page please? Its got 6 options and I have absolutely no idea how to work that out.