• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Weird ACP error reports

vexx

Active member
#1
I got the following errors today and I have no idea what to make of them.

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Duplicate entry '2968-3606' for key 'PRIMARY' - library/Zend/Db/Statement/Mysqli.php:214
Generated By: kell, Today at 10:29 AM
Stack Trace
#0 /home/tesoelit/public_html/forums/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/tesoelit/public_html/forums/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/tesoelit/public_html/forums/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
#3 /home/tesoelit/public_html/forums/library/XenForo/DataWriter.php(1612): Zend_Db_Adapter_Abstract->insert('xf_user_follow', Array)
#4 /home/tesoelit/public_html/forums/library/XenForo/DataWriter.php(1601): XenForo_DataWriter->_insert()
#5 /home/tesoelit/public_html/forums/library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
#6 /home/tesoelit/public_html/forums/library/XenForo/Model/User.php(1708): XenForo_DataWriter->save()
#7 /home/tesoelit/public_html/forums/library/XenForo/ControllerPublic/Member.php(438): XenForo_Model_User->follow(Array)
#8 /home/tesoelit/public_html/forums/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Member->actionFollow()
#9 /home/tesoelit/public_html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/tesoelit/public_html/forums/index.php(13): XenForo_FrontController->run()

There's 1 more error like this, just the Duplicate entry is different
 

Mike

XenForo developer
Staff member
#2
If it's a one off, you can likely just ignore it -- there's a potential race condition if an entry is clicked twice (in very rapid succession).
 

vexx

Active member
#3
it may be now that you mentioned, I've seen some users, write the same post twice, in a rapid succesion. Not sure if it's a XF or browser problem, but they told me they did nothing special except submit :)