1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Warn Member: URLs not parsed in Conversation

Discussion in 'Resolved Bug Reports' started by Valhalla, Jan 3, 2015.

  1. Valhalla

    Valhalla Well-Known Member

    I haven't had chance to check this more thoroughly yet.

    When warning a user via one of their posts, I opted to start a conversation. The message that I composed included a link to the forum terms of service.

    When I viewed the conversation after the warning had been submitted, the link was not active, it only became active when I edited the message, and then saved it.

    EDIT: I tested this again, with the same result.
     
    Last edited: Jan 3, 2015
    imthebest likes this.
  2. Amaury

    Amaury Well-Known Member

    Confirmed:
    • Default style
    • Add-ons disabled

    upload_2015-1-3_10-44-32.png

    After clicking Edit, but not actually editing anything, and clicking Save Changes, it shows as a link.

    (If you're curious, the user is Test Account. :p)
     
    imthebest likes this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    For the most part it is probably as designed; we don't exactly expose much there in terms of editing options so generally it is expected to just contain text, only, rather than any sort of formatting.

    That said, it possibly wouldn't hurt for us to auto link the text there. That would auto convert links to URL bb code. Incidentally, a workaround currently would be to simply wrap the text in [URL][/URL] tags.
     
    Valhalla likes this.
  4. Mike

    Mike XenForo Developer Staff Member

    I've added auto linking here. Technically speaking this prevents the case where you intentionally didn't link something, but that's fairly unlikely. You could workaround that by using PLAIN tags.
     
    Xon, Liam W and Chris D like this.
  5. Liam W

    Liam W Well-Known Member

    I've always assumed this was as designed (I've always manually added the URL bbcode).

    Thanks for adding the auto linking :)

    Liam
     

Share This Page