• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

vBulletin 4 Importer

Cory Booth

Well-known member
#41
AWESOME - Worked first time for me - no issues...
I have to say... I've tried many importers to include bringing an ASP (WebWiz Forums) to MySQL.
This entire process was smooth as silk with no errors (like left over incompatible bbcode, etc...)

Fantastic!
 

Ranger375

Well-known member
#42
It crashed on me for some reason at the end of importing the posts and for some reason didnt bring over all the forums. I'm about to try again :D
 

Edrondol

Well-known member
#46
What did you do to make them visible (to those who have permission)?
It had to do with people being in multiple user groups. If you were an Administrator and were also noted as something like Registered User it wouldn't allow you to see it. You have to really drill down through your previously set up Node permissions. In fact, you can easily tell if they were ported over or not as they do show in your node list.

Not saying that this is the same issue I had but it sure sounded like it.
 

Ranger375

Well-known member
#48
I'm getting this error, just about when my threads/posts carry over

From my error log:

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xF4\x80\x82\x83 S...' for column 'message' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
 

Edrondol

Well-known member
#49
I'm getting this error, just about when my threads/posts carry over

From my error log:

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xF4\x80\x82\x83 S...' for column 'message' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
Nope. Not the same as me. I'm out. Sorry I couldn't help.
 

Paul M

Well-known member
#55
same here I have one to transfer also.
Unfortunately, as I said, I have no knowledge of invision databases or software.

As far as this vb4 adaption is concerned, I still have one small possible issue to look into (based on some information from Georgie).
However, its not something that will affect most people.
 

thumped

Well-known member
#57
i've run into a couple of problems
  • users with duplicate email addresses
  • commas in the usernames
  • php process running out of memory after i reran the import process & it tried to display 10,000 duplicates on a single page...
 

Mark.B

Well-known member
#58
i've run into a couple of problems
  • users with duplicate email addresses
  • commas in the usernames
  • php process running out of memory after i reran the import process & it tried to display 10,000 duplicates on a single page...
That first one can't be sorted, it's how the vB3 importer works too, and apparently it's because you can log in with your email address on XenForo, so you can't have duplicates.
 

Dean

Well-known member
#59
Mark, you sure about that?

During the import it prompts for 'what to do with duplicate names' and another 'what to do with duplicate emails'. The last time I tried it, those were the prompts.
 

Paul

Well-known member
#60
Guys,

Just out of interest (just finished installing :) ), looking at importing my rather large Database and seeing if it can cope (Threads 317,654 Posts 1,673,663) and see how it handles it.

What does xF need for the import - is it just the mysql databse from the 'Donor' forum?