• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 vB4+vBSEO -> xF Redirection. Confused Beyond Repair!

TheBigK

Well-known member
#1
First of all, let me make it clear that this redirection business isn't fitting in my brain. I've been reading about the whole thing since last two days and still confused. If someone can simplify this, I'm sure lot of members would benefit.

My Current Setup:

www.domain.com -> WordPress Install
www.domain.com/forum/ -> vBulletin 4 + vBSEO installation

My xenForo Setup:

www.domain.com/community/


The steps I understand:

1. Clean install of xenForo in www.domain.com/community/
2. Import everything from vBulletin using import scripts.
3. Once import is complete, archive import log table as shown here: http://xenforo.com/help/import-redirection/

I'm not sure what exactly should I do. The files I need are here (I guess) -

http://xenforo.com/community/threads/vbulletin-4-x-url-redirection.7584/
settings: http://xenforo.com/community/threads/redirects-for-vbseod-urls.5098/

But how do I proceed after step#3? Can someone guide?
 

TheBigK

Well-known member
#3
That's it? What about the redirect scripts provided by Kier and then the setting up additional rules :| Can someone give me the steps?
 

Jake Bunce

XenForo moderator
Staff member
#6
Thanks. I'll check it out. Kire's redirect scripts work fine with vB4? Or do I need other redirect scripts?
It probably works the same in vB4, yes. Unless you are using vB4's SEO URLs which are different. Here is a script specifically for vB4:

http://xenforo.com/community/threads/vbulletin-4-x-url-redirection.7584/

But for your purposes of redirecting vBSEO vB4 URLs you should probably use Kier's scripts plus that vBSEO preset which basically lays on top of Kier's scripts:

http://tools.geekpoint.net/xfseo/
 

TheBigK

Well-known member
#8
Trying to perform vB4+vBSEO -> XF migration on my test server but can't seem to get the redirects right :(

Here's a summary of my actions so far -

My Current Setup (test clone server):

vBulletin 4 + vBSEO installed in -> domain.com/forum/
Xenforo Installation -> domain.com/community/
I've WordPress installed in domain.com.

Data has been imported and import log has been generated.

My Redirection Attempt:

I downloaded vBulletin 3.x redirection scripts by Kier. Updated the 301config.php and placed it under -

domain.com/forum/includes/

Uploaded other files from your redirect script to forum root, overwriting the existing showthread, showpost files.

Generated following rewrite rules using SHADAB's vBSEO rewrite rules for XF, and placed following lines on the top of my .htaccess file in /forum/ -

Code:
RewriteEngine on
RewriteRule [^/]+/([\d]+)-.+-([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
RewriteRule [^/]+/([\d]+)-.+.html showthread.php?t=$1 [NC,L]

Then I went to Google and searched for the terms for which we've #1 position. Click the search result link and Google Chrome says -

Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.
 

Jake Bunce

XenForo moderator
Staff member
#11
I can take a look if you are comfortable giving me your FTP login. I also need an example URL from the vB forum that I can use to test the redirects.
 

TheBigK

Well-known member
#12
@Everyone: Jake *knows* the answer for sure! I removed the old vBSEO code from .htaccess in old forum root and redirection works perfectly. The only problem now is with the member profile redirects. Don't know how to fix it :)
 

TheBigK

Well-known member
#14
This is a interesting read as I will be doing the same soon, I didnt realise the vBulletin 3.x redirection scripts worked with VB4
Once I'm done with the migration, I'll post a detailed guide on how to migrate the forums and also write step by step instructions to setup redirects :)