1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 vB4 import seems to be ok, but lots of server error logs

Discussion in 'Installation, Upgrade, and Import Support' started by woei, Feb 27, 2014.

  1. woei

    woei Well-Known Member

    Hi,

    I have set up a development environment to test my transfer to Xenforo. I have completed the import, and it looks like everything went ok.

    But when logging in to the admincp, I get the message about the server error logs. I have about 4200 of them. An example:

    Code:
    Error Info
    ErrorException: unserialize(): Error at offset 38 of 43 bytes - library/XenForo/Importer/vBulletin.php:1708
    Generated By: woei, Today at 1:55 PM
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(8, 'unserialize(): ...', '/home/forum/pub...', 1708, Array)
    #1 /home/forum/public_html/devel/library/XenForo/Importer/vBulletin.php(1708): unserialize('a:1:{s:2:"cc";a...')
    #2 /home/forum/public_html/devel/library/XenForo/Importer/Abstract.php(97): XenForo_Importer_vBulletin->stepPrivateMessages(656634, Array)
    #3 /home/forum/public_html/devel/library/XenForo/ControllerAdmin/Import.php(187): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'privateMessages', 656634, Array)
    #4 /home/forum/public_html/devel/library/XenForo/ControllerAdmin/Import.php(135): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_vBulletin4x), Object(XenForo_ImportSession), 'privateMessages', 656634, Array)
    #5 /home/forum/public_html/devel/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_Import->actionImport()
    #6 /home/forum/public_html/devel/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /home/forum/public_html/devel/admin.php(13): XenForo_FrontController->run()
    #8 {main}
    Request State
    array(3) {
    ["url"] => string(53) "http://devel.domain.net/admin.php?import/import"
    ["_GET"] => array(1) {
    ["import/import"] => string(0) ""
    }
    ["_POST"] => array(1) {
    ["_xfToken"] => string(8) "********"
    }
    }
    
    
    Should I be concerned, or can I clear the logging or is there a method to avoid these errors?
     
  2. imthebest

    imthebest Formerly Super120

    Have you forced the charset during the import to something like "latin1" or "utf8"?
     
  3. woei

    woei Well-Known Member

    Yes, forced to utf8 or else the import wouldn't work.
     
  4. imthebest

    imthebest Formerly Super120

  5. woei

    woei Well-Known Member

    Well if I don't force utf8 the import won't work. I have users with special characters.

    Also you are right about some strange things.

    België turns into België

    My vB4 database is latin1_swedish and the import only worked with utf8 so far. Any suggestions? I don't have really big issues if this only during import.
     
  6. imthebest

    imthebest Formerly Super120

    I was in the need of using utf8 by the same reason as you: I have users with special characters. The users were imported fine after forcing utf8 but then I got a lot of server errors like the one you're experiencing and also noticed that posts on my forums were having strange characters... but if you're not facing any problems then it might be ok.

    Anyway wait for advice from the developers so you can know if it's safe to ignore those error messages.
     
  7. Mike

    Mike XenForo Developer Staff Member

    First, I don't think that error should even come up with the current version of the importer -- the error should be caught and suppressed. It's possible you may have an opcode cache that is making the code behave differently, so that may be something to be aware of.

    But no, that error is generally an indication that the character set is being forced incorrectly -- the broken characters would also demonstrate this. You should likely be forcing "latin1" if it doesn't work with nothing set.
     
  8. woei

    woei Well-Known Member

    Are you referring to the version in 1.3 or should it also not show up in 1.2.5 @Mike ?

    I will rerun the import later this week with latin1 to see if it corrects the issue.
     
  9. Mike

    Mike XenForo Developer Staff Member

    Actually, I stand corrected. This is a situation where we log it instead of throwing it (unless you're in debug mode).

    Otherwise, the previous message stands (regarding forcing a character set).
     
  10. woei

    woei Well-Known Member

    If I force latin1 the import won't work. My DB is in latin1 so that is strange. I don't have an opcode cache installed or enabled. If there isn't another solution I will take it for granted that it's something to sacrifice for the migration :)
     
  11. Mike

    Mike XenForo Developer Staff Member

    When you say it won't work, what do you mean?
     
  12. woei

    woei Well-Known Member

    It gives an error when importing the posts. I searched the other day about the error and it pointed that it would be a charset error. So I forced utf8 and the import went ok except with the server error messages described as above. I know a bit of a dumb answer, but if interested I could rerun the import again tomorrow to give the exact error. I've now already rerun the import with the utf8 charset forced.
     
  13. Mike

    Mike XenForo Developer Staff Member

    Yeah, the specific error message would be useful.

    Also, in your vB install's default language, what is the character set?
     
  14. woei

    woei Well-Known Member

    Hi @Mike , the error is:

    Code:
    Server Error
    Mysqli statement execute error : Incorrect string value: '\x81Ls di...' for column 'message' at row 1
    
    [LIST=1]
    [*]Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    [*]Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    [*]Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    [*]Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1612
    [*]XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1601
    [*]XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1393
    [*]XenForo_DataWriter->save() in XenForo/Model/Import.php at line 599
    [*]XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 1684
    [*]XenForo_Model_Import->importPost() in XenForo/Importer/vBulletin.php at line 2648
    [*]XenForo_Importer_vBulletin->stepThreads() in XenForo/Importer/Abstract.php at line 97
    [*]XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 187
    [*]XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 135
    [*]XenForo_ControllerAdmin_Import->actionImport() in XenForo/FrontController.php at line 347
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    [*]XenForo_FrontController->run() in /home/forum/public_html/devel/dev/admin.php at line 13
    [/LIST]
    
    In my config.php of vbulletin I don't have a specific language specified

    Code:
        //    ****** MySQLI OPTIONS *****
    
        // When using MySQL 4.1+, MySQLi should be used to connect to the database.
    
        // If you need to set the default connection charset because your database
    
        // is using a charset other than latin1, you can set the charset here.
    
        // If you don't set the charset to be the same as your database, you
    
        // may receive collation errors.  Ignore this setting unless you are sure
    
        // you need to use it.
    
    
    No charset is specified. I hope this helps.
     
  15. Mike

    Mike XenForo Developer Staff Member

    I'm referring to the character set you have specified in vBulletin itself (in the control panel).
     
  16. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    This is what Mike is talking about:

    Screen shot 2014-03-01 at 7.42.23 AM.png
     
  17. woei

    woei Well-Known Member

    I have 2 languages and default is english-US. The settings are exactly the same as Jake's screenshot. The second language is Dutch, language code nl. Also ISO-8859-1
     
  18. imthebest

    imthebest Formerly Super120

    When I forced the charset to utf8 during the migration I got no errors but then in the xenForo control panel I saw a lof of server errors logged, all of them similar to what @woei is reporting. My charset in the vBulletin control panel was ISO-8859-1, too.
     
  19. Mike

    Mike XenForo Developer Staff Member

    So the character set for the default language is ISO-8859-1? That shouldn't be an issue then. It certainly looks like the character set conversion is failing though. I'd probably need to access the import in it's current (broken) state to attempt to debug a bit. If you can submit a ticket with ACP and FTP details to the ongoing import area, I can look into it.
     
  20. woei

    woei Well-Known Member

    Yeah no problem.
     

Share This Page