XF 2.2 vB 4.2.5 to Xenforo - file limit

N Orku

Member
Hi,

I installed Xenforo 2.2 into a test folder and commenced the import from vB. Unfortunately I hit my file limit of 250,000 during the step where attachments are imported. I have these stored in the file system, not the vB database. I have 49,000 attachments and I think I could complete the migration if I were able to move those files out of vB and into a location away from my server but still accessible to the Xenforo importer. I'm just wondering whether that is possible.
 

MySiteGuy

Well-known member
In vBulletin's attachment manager under storage type select the option to move attachments to the database. It's likely going to have a long time with that many attachments, but it will result in all those files being moved into a single database file.
 

N Orku

Member
Hi there and thanks for responding. Sorry, I should have explained myself better. I did indeed attempt to do that after hitting the file limit but vB threw its teddy in the corner and hit me with a "File upload failed" error for every single file. I tried both 777 and 755 on the attachments folder and also tried reducing the batch size to 10 but no luck. That would indeed solve my problem though I think - if vB would only do as it's told....
 

MySiteGuy

Well-known member
Simplest options at this point:

1. Get the limit increased.
2. Move to a host without those limits.
3. Get remote storage that can be mounted as the internal_data/attachments folder in Xenforo. This is a topic all by itself, which unfortunately I'm too buried with work to cover in any detail
 

N Orku

Member
Hi,

Yes, I asked my host about that and two days later I got an answer saying that they can't change it via their system, whatever that means. I have considered moving to a new host but that would mean extra expense just so that I have the space to migrate vB to Xenforo. After I have deleted vB off the server and have Xenforo up and running I would be well within the limits of my current hosting package. This is why I was looking to see whether Xenforo can import attachments from a location other than my server. Your option 3 looks to be the only way I can get around this problem and I will look into it. Many thanks.
 
Top