• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Various inconsistencies during vbulletin import

#1
Hi,

I have imported vb3.8 to xenforo on a test forum but there seem to be some inconsistencies.

For starters, I have 12,400(ish) members. In the admin panel, this figure is correct, but in the forum stats on the right hand side it says I have 9,900 members.

In addition to this, the post count is showing as higher(by a few hundred) in the xenforo forum stats than what they were in vbulletin.

Finally, I have a private moderators forum which is entirely bare of all content.

Any obvious things to try?

Thanks
 

Brogan

XenForo moderator
Staff member
#2
Have you rebuilt all the caches?

Can you search for one of the threads which should be in the private forum? Check the breadcrumb to see where it currently is.
 
#4
Well, i've rebuilt all caches and still the same stats are showing.

I've sorted out the missing forum issue. It was a permissions issue...which was odd, as it seems to have imported the permissions for a couple of other hidden forums.
 

Brogan

XenForo moderator
Staff member
#5
How many banned/unverified users do you have?

Where do you see the inconsistency in the count?
On the main ACP page or in the list of all users?

XenForo does not count banned/unverified accounts on the the forum list stat's.
 
#6
28 banned, 0 unverified

on the acp page and in the forums page the member list is 9906, but if i click on 'list users' in ACP the figure is 12,248 which is the accurate figure
 

Brogan

XenForo moderator
Staff member
#7
Do a user search on the various states such as Awaiting email confirmation, etc.

It appears you have some members who aren't being recognised as valid users.
 
#8
12,175 registered members, the remainder will be made up of various custom usergroups I have and likely a few awaiting emails. I cleared out more of the expired users awaiting emails just a day prior to importing the database
 

Brogan

XenForo moderator
Staff member
#9
I'm not sure what else to suggest at the moment.
I'm happy to take a look if you're comfortable providing an admin login.
 

Brogan

XenForo moderator
Staff member
#11
You have 2,313 members who are Awaiting email confirmation.

Essentially those members have never confirmed their accounts after initially registering.
 

Jake Bunce

XenForo moderator
Staff member
#14
Well, i've rebuilt all caches and still the same stats are showing.

I've sorted out the missing forum issue. It was a permissions issue...which was odd, as it seems to have imported the permissions for a couple of other hidden forums.
Thanks for reminding me. I encountered a permission issue during an import recently. I just posted a report about it:

http://xenforo.com/community/threads/new-forum-permissions-missing-from-vb-importer.25877/

Your problem might be the same. Otherwise the importer is very thorough about permissions. But still, some permissions don't function the same in XenForo, especially for private forums. In XenForo you need to define allowed groups instead of revoked groups:

http://xenforo.com/community/threads/understanding-permissions.5830/

Creating a private forum

Because of the way Revoke works in xenForo you shouldn't use it to restrict a private forum. Instead you should use a special feature in xenForo called Private node. You will see the Private node checkbox when editing the permissions for a specific node. This basically inverts the permissions so that you can specify Allowed groups instead of Revoked groups. This is actually better for group management if you add more groups later.

Admin CP -> Users -> Permissions -> Node Permissions -> [select a forum] -> Private node
 
#16
My host has moved the folders containing avatars and attachments from my vbulletin server to xenforo server. If i move the files into the xenforo counterparts will the attachments and avatars display on xenforo or is that wishful thinking?
 

Jake Bunce

XenForo moderator
Staff member
#17
My host has moved the folders containing avatars and attachments from my vbulletin server to xenforo server. If i move the files into the xenforo counterparts will the attachments and avatars display on xenforo or is that wishful thinking?
You can't just transplant them like that. Attachments and avatars have to go through the importer.
 

Jake Bunce

XenForo moderator
Staff member
#19
Attachments are brought over during the import. If they are stored in the file system in vB then it asks you for the path.

If the attachments were not imported then the import needs to be run again if you want the attachments.