• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Awaiting feedback Using special characters in Category/Forum nodes will cause redirect loop

#1
I saw another thread that seemed loosely related to this, although it was about thread titles only. An issue I have noticed on my board is that when I use special characters in a Category/forum node, it will cause a redirect loop. The steps to recreate it were rather easy.

  • Add forum/category node
  • Give it a title with any kind of special character, ie: é, á, €, ç
    • Dollar ($) was giving no issues however
  • Click/goto the category/forum and you'll notice that the page ends up in a redirect loop.
For forums this was easily worked around by giving it its own url structure when setting up the forum node. However for categories this is more difficult.

Setting a route filter, and in that filter replace the special characters with 'normal' ones did not help either. The only way around it is by using the route filter in this way:

  • Create category node test-é (gives redirect loop)
  • Find the replacement text that normally is shown in urls with special characters
    • categories/test-%C3%A9.214/
  • Create a route filter with the above line (simply using 'categories/test-é.214/' won't work).

The thread I referred to in my intro was this thread: https://xenforo.com/community/threa...ng-special-characters-in-thread-title.111408/
 
Last edited:

Chris D

XenForo developer
Staff member
#2
Can you give a more specific example of a forum title that triggers this and what the resulting URL is when this fails?

I have just tested this and, like the other thread, it works perfectly fine for me locally.
 
Last edited:

Brogan

XenForo moderator
Staff member
#3
I just tested on my local using the same characters (Å é, á, €, ç) in a node title and it loads normally.

Edit: On further testing, if a URL portion isn't entered it results in a 404.
Edit 2: But only if the Å character is used.
Edit 3: No problem on my production server, just on my local using XAMPP.
 
Last edited:

Zenexer

Active member
#5
Do you have the "Romanize Titles in URLs" option enabled? It's under "Basic Board Information". What's your primary language?

@Brogan What charset is PHP using? And mbstring? (on your XAMPP installation)