Using DigitalOcean Spaces or Amazon S3 for file storage in XF 2.x

Using DigitalOcean Spaces or Amazon S3 for file storage in XF 2.x

No permission to download
Tested this out with DigitalOcean and it works great! The only point of feedback would be to add support for DigitalOcean's Spaces CDN endpoint. CDN comes for free when you use DigitalOcean Spaces, but when you try to use it with this system it gives a 403 error.

I had this issue as well but I think it just takes a while for the CDN to propagate all the file permissions or something. I used the normal endpoint and then after a few days I tried switching it to the CDN endpoint (a custom domain) again and it worked.

Make sure you used the public ACL option when you used S3cmd to copy your files.
 

briansol

Active member
aws n00b...

everything seems to be working as far as i can see from the xf side but i'm getting the 403 on the write to s3. I'm struggling with applying the policy to the bucket. I've made the bucket and the IAM but i can't figure out the correct way to attach it VS the public/private bucket selectors.

Is there a quick ref guide to help guide me? I ran the instructions 4 times and i'm still broken so i'm not getting it... I realize this is a bit outside of supported realm here...
 
Last edited:

OyuncularSehri

New member
Hello @Chris D,

Can you help backblaze configuration?

 
Top