1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Users don't stay logged in.

Discussion in 'XenForo Questions and Support' started by Mike Krall, Jun 9, 2015.

  1. Mike Krall

    Mike Krall Member

    For some reason users don't stay logged in (even with the 'stay logged in' check box checked) meaning when they return to the site their user name and password isn't already filled out.

    So if I go to my site I have to start typing in my name and it will auto fill the password. Other xenforo sites I visit keep me logged in so I don't have to type anything.

    I'm not sure if this is a browser issue or xenforo setting.

    Thanks for the help!
     
  2. Amaury

    Amaury Well-Known Member

    This sounds like an add-on at play. Disable all add-ons and see if the issue persists.
     
    Mike Krall likes this.
  3. Steve F

    Steve F Well-Known Member

    Is your site accessible from www and non www? That would be my first guess.
     
    Mike Krall and Amaury like this.
  4. Amaury

    Amaury Well-Known Member

    Oops, forgot about this. Check this as well.
     
  5. Mike Krall

    Mike Krall Member

    Just added our first add-on last week and this has been going on from the beginning so can't be that.
     
  6. Mike Krall

    Mike Krall Member

    Yes, it is:

    http://www.the-teh.com
    http://the-teh.com

    Curiously though about 2-3 weeks ago our host transitioned to new servers and our site wasn't accessible with the www pre-fix. Still even before that incident it wasn't remembering log-ins. The forums are imported from SMF, would that have an effect?
     
  7. Amaury

    Amaury Well-Known Member

    You should be forcing users to one or the other--either WWW or non-WWW.
     
    Mike Krall likes this.
  8. Mike Krall

    Mike Krall Member

    hmm from the above post, when I click the first www link I'm not logged in.

    When I click the second link without the www I'm logged in.

    What's that mean?
     
  9. Mike Krall

    Mike Krall Member

    You mean verbally tell them that or is there something wrong with how I have urls setup?
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    The FAQ in my signature explains how to force it to one or the other.
     
    Mike Krall likes this.
  11. Amaury

    Amaury Well-Known Member

    It means you've logged in on the non-WWW version, but not the other.

    You'll want to create a redirect so that if someone types WWW, it will force them to the non-WWW or vice-versa.
     
    Mike Krall likes this.
  12. Mike Krall

    Mike Krall Member

    Thanks, that should be required reading :)

    Let me go brush up on my php and attempt that fix.
     
  13. Liam W

    Liam W Well-Known Member

    Nothing to do with PHP :)

    Liam
     
    Last edited: Jun 9, 2015
  14. rafass

    rafass Well-Known Member

  15. Mike Krall

    Mike Krall Member

    Isn't that what the coding is?
     
  16. Mike Krall

    Mike Krall Member

    I guess I need to check what I setup in google for preference and then set it to that.

    Thanks for the code :)
     

Share This Page