• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Users can't upload an avatar

#1
I have users that when they hover over their name, there's no place to upload an avatar. I've gone in and even given them special permission to do this but it's still not working. I want all registered users to have the ability to upload an avatar. How can I do this?

And, I've just spent a half hour going through the manual and searching the forums to see if anyone else has had this problem. Maybe I don't know what key words to put in.

Thanks!
 

Brogan

XenForo moderator
Staff member
#2
Check the user group permissions for Avatar Permissions.

They should be allowed to upload and the maximum size needs to be greater than 0.
 
#5
If the permissions are correct then they should have access to the equivalent link to this on your site: https://xenforo.com/community/account/avatar
In a perfect world, yes, they should. However, I was doing a Zoom chat with the person and she was sharing her screen. There's no place that even allows for her to upload an avatar. The space on the left where it should be available is completely missing. Because of that, she can't see it under her account. While sharing her screen, she went into her account and what you shared is not showing for her. I had to upload her avatar for her because she simply couldn't see a place to do it.
 
#6
PS... She is also having issues with the two-step verification. Maybe it's her computer settings? I watched as she tried to disable the two-step verification and then when she went in again, it required her to set up the two-step verification to go further. No one else has had this issue so I'm wondering if it's an individual problem?
 
#7
Other registered users are not able to upload an avatar. It's now not limited to the one person mentioned above. When using the drop-down menu under their name, the word "avatar" is missing. All of the user permissions (with the exception of unregistered) have been given the ability to upload an avatar. I've checked and double checked. However, @Brogan the link you provided above is what they should see but aren't, even with the proper user permissions. It's simply still not working. Is there anything else I could be missing?
 

Tracy Perry

Well-known member
#8
Are you by chance running any add-ons that deal with the avatars? If so, disable them. If you are SURE that all permission sets are correct, then it should be showing.
Does it work for you?
Is this a custom style? Have you tried the default style?
 
#9
Are you by chance running any add-ons that deal with the avatars? If so, disable them. If you are SURE that all permission sets are correct, then it should be showing.
I have no add-ons that do anything with avatars. I've double and triple checked the permissions. The most important one is registered users, correct? That one is set to "allow." The only one that isn't set to "allow" is the unregistered. ALL other users should be able to have an avatar.

Is this a custom style? Have you tried the default style?
The only "custom" things I've done are to change theme colors and add a banner. If you want to look, here's the site: www.kingdomtribes.com.

And, no, I've not been able to get this to work correctly. People still can't upload an avatar because there's no place for them to do it.
 

Neal

Well-known member
#10
I've just registered on your site and this is the message I see when clicking the avatar location from my profile:

The following error occurred:

You do not have permission to view this page or perform this action.

Untitled.png
 
#11
I've just registered on your site and this is the message I see when clicking the avatar location from my profile:

The following error occurred:

You do not have permission to view this page or perform this action.

View attachment 156264
That's what everyone is getting. Maybe I'm missing something still that's super simple. What that is, I don't know.
 

Neal

Well-known member
#12
Is it possible they are added to another usergroup as secondary where the avatar permissions are set to "Never"?

Scrap that as i'm just a normal user on there.
 
#13
Is it possible they are added to another usergroup as secondary where the avatar permissions are set to "Never"?

Scrap that as i'm just a normal user on there.

All of the usergroups are set to "allow" with the exception of unregistered users who are set to "no." The only thing I have marked as "never" is the two-step verification. I hate it and so do the users on the site. It's a major pain in the butt. (n)
 

Tracy Perry

Well-known member
#14
All of the usergroups are set to "allow" with the exception of unregistered users who are set to "no."
It's still sounding (and looking from the screenshot above) to be a permission issue.
If you want to start a convo with me and grant me temp admin access I can take a look at it and see if I find it fairly quickly. Am currently battling a UEFI restore to a system that was configured to use legacy BIOS (what a PITA). But it should be something simple.
 

M@rc

Well-known member
#15
It's still sounding (and looking from the screenshot above) to be a permission issue.
If you want to start a convo with me and grant me temp admin access I can take a look at it and see if I find it fairly quickly. Am currently battling a UEFI restore to a system that was configured to use legacy BIOS (what a PITA). But it should be something simple.
I've already taken a look and solved it :p Upload size was set to 0.
 

Tracy Perry

Well-known member
#16
Had a feeling that was the issue....
Honestly all the sub groups should be set to inherit and the ONLY place that should be set is in the registered members group.
The only exception is if the admin desires to allow larger avatars for certain groups (file size, etc).
As Brogan stated above, there are typically 2 reasons for the "you don't have permissions" issue... file permissions would give a different error.
 
#17
It's still sounding (and looking from the screenshot above) to be a permission issue.
If you want to start a convo with me and grant me temp admin access I can take a look at it and see if I find it fairly quickly. Am currently battling a UEFI restore to a system that was configured to use legacy BIOS (what a PITA). But it should be something simple.
I think we got it fixed. Can you try again and see if you get the same error?
 
#18
Had a feeling that was the issue....
Honestly all the sub groups should be set to inherit and the ONLY place that should be set is in the registered members group.
The only exception is if the admin desires to allow larger avatars for certain groups (file size, etc).
As Brogan stated above, there are typically 2 reasons for the "you don't have permissions" issue... file permissions would give a different error.
So, should I go back in and set all other user permissions to inherit?
 

Tracy Perry

Well-known member
#19
If you have it to something other than that (avatar specific), then yes I probably would. It should pick up the base Registered group's settings and only time you would set anything else is if you want to prohibit for that group or if you want to allow larger. That way it reduces the number of places (groups) you have to look in since they will primarily inherit from the registered users group.
 
#20
If you have it to something other than that (avatar specific), then yes I probably would. It should pick up the base Registered group's settings and only time you would set anything else is if you want to prohibit for that group or if you want to allow larger. That way it reduces the number of places (groups) you have to look in since they will primarily inherit from the registered users group.
Thank you! I'm now clueful. The manual is not clear at all so this is very helpful.