1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Usergroups and Permissions

Discussion in 'Troubleshooting and Problems' started by Kim, Nov 8, 2010.

  1. Kim

    Kim Well-Known Member

    I set up a new Usergroup, and gave the UG a load of permissions - pretty standard kind of ones for a regular member based group.

    I applied the UG to a test member, and now that member's posts are on Moderator Queue... :S

    Confuzzled... What sets that option? Setting the Follow message moderation rules: to Allow or Default seems to make no difference, I have tested both.

    UG_permissions.jpg
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Does the problem go away when you remove the user from that group?

    After reviewing the list of group permissions I don't see any other permission that affects moderation. Maybe the permission is set elsewhere, like for the user account itself or in the node permissions:

    Admin CP -> Users -> Permissions

    > User Group Permissions
    > User Permissions
    > Node Permissions
     
  3. Kim

    Kim Well-Known Member


    Moving the test member back to the Members group elminates the issue, so it would appear to be the UG set up, so the big question is how to fix it :S odd.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I just created a test group and added a user to it (removing them from the registered group).

    All I set to Allow was Follow message moderation rules: and Post new thread:

    I was able to post OK with that.

    acp_permissions_post.PNG
     
  5. Kim

    Kim Well-Known Member


    Hmmm will try that, but I have to wonder if this is as it should be? Surely the other options should be selectable too?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    The "Follow message moderation rules" is definitely the permission for posts being posted without approval.
    The other permissions shouldn't affect it so yes, you should be able to set those as you wish.
     
  7. Kim

    Kim Well-Known Member

    Ok.. setting it exactly as you have it in the image... had the effect of my testuser not being able to post at all.

    UG_test.jpg
     
  8. Kim

    Kim Well-Known Member

    OK I think I have it now.. I had it set as I did originally, with all the options set to on, and for some reason it is now working.

    I think the issue is my test user is using IE which caches like a demon and he wasn't getting the new permissions when I applied them.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Glad you sorted it.

    I had another good look at the usergroup/node/user perms and couldn't see anything else so was confused why it didn't work.

    P.S. Give your tester a slap from me for using IE :D
     
    Dragonfly and Jo. like this.
  10. Dean

    Dean Well-Known Member

    That got me too, badly. Could not figure out what was going on. Hard refresh worked for me (control F5). But I was using fire fox.
     
  11. Kim

    Kim Well-Known Member


    Firefox has gotten very "Cachey" lately too I have noticed.

    Thanks for your help lads :)
     
    Dean likes this.
  12. Dean

    Dean Well-Known Member

    I split Dons issue off into another thread in the bug reports forum to be sure it is not lost.
     

Share This Page