• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

User Group Based DoFollow URLs 1.0

No permission to download
Status
Not open for further replies.

karoshio

Active member
#5
Just curious about how you say it allows dofollow for people other than Administrators but my signature has always been nofollow on my forum. Was this a typo?
 

Chris D

XenForo developer
Staff member
#6
There's two things here that are handled quite differently by default.

There's URLs in signatures and then there's URLs in posts. Both are handled differently.

URLs in signatures are nofollow for everyone including moderators and administrators.
URLs in posts are only nofollow for Registered members meaning Moderators and Administrators who post external URLs do not have nofollow.

The best demonstration is this:

http://xenforo.com/community/threads/shared-hosts-optimized-for-xenforo.32268/#post-368475

This post by Slavik contains a URL. As he's staff it doesn't have nofollow:

Code:
<a href="https://www.viocom.co.uk/vps/forum-hosting" target="_blank" class="externalLink">https://www.viocom.co.uk/vps/forum-hosting</a>
Yet if you check the source of this post, you'll see that because I'm not staff it does have a nofollow: https://www.viocom.co.uk/vps/forum-hosting

To further demonstrate my point, Slavik has an external URL in his signature. Even though he's staff, he does have a nofollow set:

Code:
<a href="http://www.p8ntballer.com" target="_blank" class="externalLink" rel="nofollow">www.p8ntballer.com</a>
Now, if my add-on was installed, his signature link would look like:

Code:
<a href="http://www.p8ntballer.com" target="_blank" class="externalLink">www.p8ntballer.com</a>
With my add-on, the URLs in posts and the URLs in signatures are treated the same. That is, if you are "trusted" (that's Moderator, Administrator, Super Administrator or any other usergroup specified in my add-on) then your URLs in posts will not have nofollow and your URLs in signatures will also not have nofollow.

I feel like I've just over-explained that o_O

But I like to be thorough in my explanations :D

Hopefully at least part of that answers your question :)

While I remember, this is potentially very important: Although my add-on does allow some usergroups to have URLs without the nofollow attribute set, please remember that signatures are by default hidden to guests. If you want to have dofollow signatures, please remember to allow guests to view signatures via the setting in the Admin CP. Search: "guestshowsigntures" otherwise Google and other search engines won't see the signatures anyway when crawling you.
 

Chris D

XenForo developer
Staff member
#8
Hi..i dont understand..
if i choose admin..admin will notfollow or dotfollow??? :(
This add on makes it possible for users to post links which are "dofollow".

If you select admin - it won't have any effect on the URLs they put in posts (these are dofollow by default), but it does have the added benefit that their signature URLs will be dofollow too.
 
#10
Hi Chris,
When i active that Add-on. have some problems here. I try to choose other group but not working..i must view that image on other tab.
But when i turn off add-on, everything are nomal :cry:
 

Attachments

Chris D

XenForo developer
Staff member
#11
Hi Chris,
When i active that Add-on. have some problems here. I try to choose other group but not working..i must view that image on other tab.
But when i turn off add-on, everything are nomal :cry:
I don't understand.

Can I have a URL where I can take a look at the problem myself?
 
#12
I don't understand.

Can I have a URL where I can take a look at the problem myself?
:( tôi không biết đây có phải là một lỗi hay không? nhưng khi tôi cho addon hoạt động thì mọi hình ảnh trong các bài viết của tôi đều phải chuyển sang một thẻ mới. Giống như hình ảnh tôi đã đăng ở trên. Mọi hình ảnh đều được đưa về dạng " View attachment + một số nào đó ". Nhưng khi tôi cho Addon đó ngừng hoạt động tôi lại có thể xem ảnh ở trong bài viết của mình mà không phải mở thêm thẻ mới nào cả
Please use google translate :)
Hope you can understand and fixed it.
Thank you
 

kprojects

Well-known member
#13
Thanks for creating the do-follow addon - I'm using it to try and sell premium memberships on my webmaster forum.

However, I noticed that when it is enabled, thumbnails and full-size images don't show on threads.. they show up as a link to the attachment in a new window..

Example: http://www.webmaster.cm/threads/dont-fear-the-penguin-white-hat-seo.553/
viewattachment.png
When I disable the add-on, the attachment image shows how it should.

This is for any user.. whether they are in a 'trusted' group or not (if that helps)..

Any ideas?

Thanks,
Rob
 

Chris D

XenForo developer
Staff member
#15
Sorry for the late response, I will have to install this on my test box and let you know.

EDIT: Just noticed the post above yours - looks like some guy was having the same problem.
 

surfsup

Well-known member
#18
I see inside the Blogs I have do-follow backlinks but how can I make sure my paid members do to? It works for them inside threads but not inside the blog feature, can you help me out on this? thx!
 

surfsup

Well-known member
#19
Thanks for creating the do-follow addon - I'm using it to try and sell premium memberships on my webmaster forum.

However, I noticed that when it is enabled, thumbnails and full-size images don't show on threads.. they show up as a link to the attachment in a new window..

Example: http://www.webmaster.cm/threads/dont-fear-the-penguin-white-hat-seo.553/
View attachment 33095
When I disable the add-on, the attachment image shows how it should.

This is for any user.. whether they are in a 'trusted' group or not (if that helps)..

Any ideas?

Thanks,
Rob
This is happening to me as well, have you had any luck with this yet?
 
Status
Not open for further replies.