• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 URL Redirect Help needed!

zooki

Active member
#1
I had VB Standard URLs. The redirects work. However, I moved my Xenforo installation to the root. I am using Xenporta. It all works, except i get a conflict with Xenporta. Right now it works if I use /community as the forum index route. Is there a way I can modify the htaccess to let me use /forum.

I changed my filedir in 301config.php to as follows:

$fileDir = '/mnt/Target01/327993/www.mysite.com/web/content/';
and my .htaccess is :

Code:
#Mod_security can interfere with uploading of content such as attachments. If you
#cannot attach files, remove the "#" from the lines below.
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
#If you are having problems with the rewrite rules, remove the "#" from the
#line that begins "RewriteBase" below. You will also have to change the path
#of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo
 
#This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^forum/(.*)$ http://mysite.com/$1 [R=301,L]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>



Thank You.
 

zooki

Active member
#2
i partially fixed my original problem by adding the line

Code:
RewriteRule ^forum/(.*)$ http://mysite.com/$1 [R=301,L]
This lets you move from /forum to the root, and have the rewrites.

I still want to keep "/forum " as my virtual forum root, any idea how I can do that??