• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed URL in Editor

erich37

Well-known member
#1
1)
when writing a URL into the Editor like for example:

www.yahoo.com

then if you edit / change the very same text into www.cnn.com , the URL to CNN does not work.



2)
when writing a URL into the Editor, then the URL only gets linked once you click the "Enter" key on your keyboard. It does not automatically turn the text into an URL-Link.
It does not turn the URL-text into a Link when you click the "space"-key on your keyboard.


For both items, not sure if this is a bug or normal behaviour. Or if anything can be done about it.


Windows 8 / Firefox 21

:)
 

AndyB

Well-known member
#2
This auto linking url's as we type is new to Redactor isn't it? I question what benefit it has and weather it might be best to disable this function. Disabling the function would certainly fix the bug mentioned by Erich.
 

erich37

Well-known member
#3
This auto linking url's as we type is new to Redactor isn't it? I question what benefit it has and weather it might be best to disable this function. Disabling the function would certainly fix the bug mentioned by Erich.
no idea what this is... but it is definitely confusing.

you think you have correctly changed the Link-URL, but then you suddenly realize (if you check at all) that the URL does not work when you click onto the Link.....

:eek:
 

Mike

XenForo developer
Staff member
#4
If you are editing an existing link, you're just changing the text rather than the link when you edit like that. So that much is expected and can't really be fixed - it's ambiguous as to what behavior is actually desired.

That said, disabling the autolink would prevent it in that it happens because the link was inserted. I think I may do that.

#2 is expected.