• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Won't fix [URL] changes to [url] with rich text editor disabled

soloarquitectura

Well-known member
#1
Chrome 39.0.2171.95 m, Windows 8.1 x64, XenForo 1.4.3

Sample:

Type: [URL]https://xenforo.com/community/[/URL]
Save Changes -> Edit -> BB Code Editor:
[URL]https://xenforo.com/community/[/URL]

Preferences -> Disable Use the rich text editor
Type: [URL]https://xenforo.com/community/[/URL]
Save Changes -> Edit:
[url]https://xenforo.com/community/[/url]
 

soloarquitectura

Well-known member
#5
Another sample:

Preferences -> Disable Use the rich text editor
Type: [URL]https://xenforo.com/community/[/URL] [B]Hello World[/b] [i]Test[/I]
Save Changes -> Edit:
[url]https://xenforo.com/community/[/url] [B]Hello World[/b] [i]Test[/I]
 
Last edited:

Mike

XenForo developer
Staff member
#6
I'm changing this to use caps as we do elsewhere, but otherwise I won't be changing anything here at this point. This has to do with autolinking and specifically automatic media embedding code. The URL tag gets passed off to the autolinker which handles simplification and media embedding and returns the necessary BB code. This could be adjusted to some degree, though at the least, it would require a function signature change which could trigger a backwards compatibility break for something that is really the edge of an edge case.