• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Urgent: An unexpected error occurred. Please try again later

Valter

Active member
#1
I wanted to remove unneeded files from the server, so deleted them all but my images/avatars/attachments...
Then I uploaded just original XF 2.0 files.

I got blank page on my forums and 'An unexpected error occurred. Please try again later.' when tried to point browser to /install.

Then I restored my files backup from XF 1.5, then updated them by uploading XF 2.0 files.
Again same blank page and errors.

Any ides?
 

Chris D

XenForo developer
Staff member
#3
You said you removed all files, which I presume includes your src directory. This is where your config file is.
 

Valter

Active member
#4
You said you removed all files, which I presume includes your src directory. This is where your config file is.
I've created config file in src but it didn't help.

I guess there were some important cache files in src and/or in data/internal_data folders without Xenforo is not able to load forums.
 

Jake B.

Well-known member
#5
I've created config file in src but it didn't help.

I guess there were some important cache files in src and/or in data/internal_data folders without Xenforo is not able to load forums.
You definitely won't want to delete data or internal data. data has your thumbnails/avatars and internal_data has attachments and cached templates
 

Chris D

XenForo developer
Staff member
#6
You suggested that you deleted them all but your images/avatars/attachments which I assume you meant you left your data and internal_data directories alone (this is where those items are stored).

Please don't go blindly removing files and directories. It's a good job you had a backup!
 

Valter

Active member
#7
I guess 'An unexpected error occurred' happened on /install because of set_time_limit in App.php which is not allowed on my server. That's why I wasn't able to try with rebuilding master data from there...