1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Upoading a large PDF

Discussion in 'Troubleshooting and Problems' started by Craig, Jan 11, 2013.

  1. Craig

    Craig Active Member

    I am trying to up load a pdf that is quite sizable. It is 15 mb. I have increased the allowable limit for uploads with no success.
    I get the following error message "There was a problem uploading your file. "

    in options I changed the allowable limit to 15,000,000,000 but nothing works.

    Thanks in advance for the help!
  2. MattW

    MattW Well-Known Member

    What is the setting in your php.ini file for the max_upload ?
    Jake Bunce likes this.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is the generic upload error. It's not specific.

    You are probably exceeding a server limit. Here are some server settings that may be limiting:


  4. digitalpoint

    digitalpoint Well-Known Member

    You may want to check your normal server logs... it's quite possible whatever is causing it is logging the error with some more info (check web server error logs, PHP error logs, etc.)

    There are also settings in your web server that will affect it...

    Also, if your site happens to use Nginx, check the client_max_body_size.

    I also can't stress enough to not ignore the MySQL settings Jake mentioned. I made the mistake of upping the PHP/web server limit one night, and totally forgot MySQL's max packet size. I tested uploading a big file... it worked and so I left and went to dinner (as in drove away and was gone for a couple hours). Needless to say, the allowed packet size being smaller than the file being uploaded causes all the slave DB servers to halt all replication with the fatal error. That was super fun. :)
    MattW and Jake Bunce like this.
  5. Nelson T.

    Nelson T. Guest

    Where in my home directory is the PHP.ini and other settings?
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Navigate to admin.php?tools/phpinfo in the ACP.

    It will list the path there.

  7. Nelson T.

    Nelson T. Guest

    It comes up:

    Configuration File (php.ini) Path /usr/lib
    Loaded Configuration File /usr/local/lib/php.ini

    My web hosting company will have to change that- I don't think I have access.
  8. Nelson T.

    Nelson T. Guest

    My max is 64M

  9. Brogan

    Brogan XenForo Moderator Staff Member

    There are three places to change php values: php.ini, config.php and .htaccess.

    If possible, changes should always be made in php.ini, but not everyone has access to that, depending on server setup.

    Changes made in .htaccess only apply as an Apache module.
    Config.php changes will always apply and happen after some XenForo changes.
    Certain things however can't be changed in config.php, post_max_size for example, as it must be done before php starts to handle the request.
  10. Nelson T.

    Nelson T. Guest

    I don't see config.php- where is it?
    .htaccess s in severa locations.
  11. Nelson T.

    Nelson T. Guest

    I had them increase PHP to 512M.

    My Config.php only has the following:

    <?php $config['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = 'xxxxxxxx';
    $config['db']['password'] = 'xxxxxxxxxx';
    $config['db']['dbname'] = 'xxxxxxx';
    $config['superAdmins'] = 'xxxxxxx';

    xxxxxs to preserve privacy.
  12. Nelson T.

    Nelson T. Guest

    I am still getting the download too large errors despite increasing the PHP Max size. Anything else it could be?
  13. Brogan

    Brogan XenForo Moderator Staff Member

    You haven't actually stated what error you are receiving.

    Your first post in this thread was simply:
    It's always a good idea to start a new thread for any issues or problems, clearly explaining what they are.

    You need to check all of the other settings posted earlier in the thread, assuming you are having the same issue: https://xenforo.com/community/threads/upoading-a-large-pdf.43193/#post-464969
  14. Nelson T.

    Nelson T. Guest

    Getting this error. The web host increased PHP.ini to 512M. I also checked and set all the settings to "unlimited"

  15. Sunka

    Sunka Well-Known Member

    What did you setup in Admin control panel for Maximum Attachment File Size (KB) option?
  16. Nelson T.

    Nelson T. Guest

    Where is that located please?
  17. Amaury

    Amaury Well-Known Member

    Options > Attachments
  18. Nelson T.

    Nelson T. Guest

    I apologize. I thought that if I set that to "0", it would be unlimited, like it is on VB.

    Instead, it was the source of my problem. I set it now to a very large number.

    Thanks for all your assistance.

Share This Page