1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Uplpoad attachments to posts - step-by-step w/ images

Discussion in 'Troubleshooting and Problems' started by Euler Kernighan, Aug 12, 2014.

  1. Hey guys,

    I might need your help here. I exhaustively looked for a solution to this problem, read entire others threads but i give up on this I or any other administrator can upload attachments to posts on my board.

    Just took some screen shots to help you to help me, the file that I'm trying upload is about 152k .jpg :D

    On my troubleshooting I've started trying the regular way, just click on "Upload File" buttom and after 100% complete hit save:

    STEP 1:
    [​IMG]


    As you can see on the image bellow nothing happens:

    STEP 2:
    [​IMG]


    STEP 3:
    My user belongs to Administrative, Moderating and Registered users, so I accessed each one of this groups and set the "Upload attachements to post" as Allow:

    [​IMG]


    STEP 4:
    Also checked the Options > Attachements:

    [​IMG]


    STEP 5:
    Checked the permissions on Applications > Node Permissions for Category and Forum, and set it as Allow for each single group:

    [​IMG]


    STEP 6:
    After that run in to Analyse Permission and analyse Permissions for my user and the node, with the same result:

    [​IMG]

    STEP 7:
    Analyse Permissions detailed:

    [​IMG]


    STEP 8:
    As a last resource, I've checked permissions on server's folders as:

    [​IMG]



    Do you guys have any other suggestion or it's time for a ticket?

    Thanks in advance!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Does the uploaded attachment show below the editor after it reaches 100%?
    If not, it is not actually completing the upload.

    Try disabling the flash uploader and see if it works then.
     
  3. @Brogan thank you for being so patient and respond another "upload attachements to post" error thread. :confused:

    No, the attachment never show below the editor - I've waited for long 3 minutes (just count on android :p)

    I followed your advice and unchecked the Options > Attachments DEselected "Use Flash Uploader" and trying again but this time something very curious occurs:

    1) Logout from Admin and Forum;

    2) Restarted the browser (I'm using Google Chrome) and logged in the forum, tried to upload that same file and the upload interface remains in Flash (??? that blue bar in percentage). I don't know why or how this is possible, but it happened.

    3) Downloaded and installed Mozila Firefox without install any plugin, try to access the forum and upload an attachment and... ta-daaaa!!! As a magic it works! BUT (and this is a huge but), browser asks to download and install Adobe Flash Player (I've just ignore it before to make the upload just for the sake of this test)

    4) Installed the Adobe Flash Player plugin (Shockwave flash 14.0.0.179) and when I tried to make another upload, the interface has changed back to flash :mad: and the upload NOT worked, showing the follow:

    [​IMG]


    5) Got in to browser configuration and disable the shockwave flash try it again and guess what?!

    [​IMG]



    Ok, the solution for this problem is not turn off this or any other plugin once the same is happening with all registered users.

    Do you have any other ideas? :confused::(
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It could be related to mod security.

    Contact your host and explain the problem and they should be able to resolve it.

    You can actually disable it in .htaccess if needed.
     
  5. how can I do that, the .htaccess thing?

    Any others users out there hosting xenForo on Siteground.com face the same problem?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    I have just replied to your ticket.

    Uncomment these lines in .htaccess:

    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>
     
  7. OMG, I don't know you work for the company, shame on me :oops:

    Really appreciate your support and commitment to solve this problem.

    I can say that: EVERYTHING WORKS FINE! thanks to Brogan! (y)
     

Share This Page