1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Uploaded file is too large - but it isn't

Discussion in 'Troubleshooting and Problems' started by rwm1962, May 24, 2015.

  1. rwm1962

    rwm1962 Active Member

    I'm setting up & testing the attachment settings. I have a 8192kb max file size & max attachment image dimensions 0f 1000px x 1000px.

    When I try to upload an image that is 3994kb I get the following error:

    The pixel size is 3648 x 2736 = 9980928

    I have the following in my config.php as per Brogans FAQ;

    $config['maxImageResizePixelCount'] = '20000000';
    Have I added that code wrong? Or do I have another issue? Image loads fine here.


  2. Brogan

    Brogan XenForo Moderator Staff Member

    What is max_upload_size set to in PHP?
    Chris MacAskill likes this.
  3. rwm1962

    rwm1962 Active Member

    I have upload_max_filesize 2M

    I'm guessing that's someting I need to get my service to change? Even though the image is re-sized on posting to around 300kb?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It needs to be changed in php.ini but if you contact your host they should be able to help.
    rwm1962 likes this.
  5. rwm1962

    rwm1962 Active Member

    Thanks Brogan. I'm getting bold - managed it myself! Retried the file above & it works fine.

  6. Liam W

    Liam W Well-Known Member

    The full image is uploaded before the server resizes it, therefore it has to be within PHP's limit :)

    wedgar and rwm1962 like this.
  7. Ah. That was the ticket for me too.

Share This Page