1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upload issues after restoring database

Discussion in 'Troubleshooting and Problems' started by Jonathan David Bloom, May 11, 2011.

  1. Through my own stupidity, I did something to cause the forum database to mess up. I reverted to an earlier backup and now users can't upload anything. In the flash and non-flash uploaders. It halts at 100%

    Now, there were some attachments posted during the interim, could this have caused an issue?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Did you make any changes on the server or files which coincided with this issue?
  3. Nope, merely restored the database.
  4. Lawrence

    Lawrence Well-Known Member

    Attachments are stored in the file system with their own file hash, I can not see having more attachments stored in the file system than the DB knows about, interfering.

    What version of XenForo is your database back-up based on? If it is not the same version you may have to run an upgrade as some templates may be out of date.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    I can't imagine that any attachments uploaded prior to restoring the backup would have any effect, but you can always delete them from the /data and /internal_data directories, assuming you know which ones they are?
  6. Aha! Found the culprit! The Flash uploader for some reason was acting weird. I turned it off and now it works.

    I tested it with flash uploader off and it didn't work, but now it works with it off.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Does it work when you turn it back on?

    The only few times I've heard of it not working are to do with server configuration, usually mod_security.
  8. It doesn't work when the flash uploader is enabled.

    Mode_security isn't enabled as far as I know.

    I added the following to my htaccess and it doesn't seem to fix the issue.
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I can't understand then why this was working previously but no longer after a database restore.
    I've done tons of restores on my local and live installations and never had an issue.

    I suppose you could always try uploading the files from the upgrade package again, to rule out any issues there.

    Other than that, you could ask your host if they've changed anything on the server recently.

Share This Page