• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Upgrading XFES 1.x -> XFES 2.x with ElasticSearch pre-2.x

Affected version
2.0 Beta 4

Xon

Well-known member
#1
XFES depends on 2.x or newer, and this is validated when looking at the configuration page preventing you from activating XFES with an old version.

However, this is not validated when doing an upgrade from XF 1.x -> XF 2.x.

Perhaps the installer should validate requirements if XFES is already configured?
 

Mike

XenForo developer
Staff member
#2
We can't really do a standard validation here, but if your current server doesn't meet the requirements when upgrading to XFES2, we will disable using it for searches. The XFES config page also displays an error message in this case.