1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Upgrading to 1.2.1?? What am I Doing Wrong?

Discussion in 'Installation, Upgrade, and Import Support' started by MistyMeanor, Sep 8, 2013.

  1. MistyMeanor

    MistyMeanor Active Member

    I have never upgraded the forum itself, by myself. I have followed instructions to the "T" from brief instructions from others, and reading the manual. But am fairly noviced at using FTP.

    But, I have downloaded from the members area numerous times and made sure to check off that I JUST wanted the upgraded version.

    I then ONE BY BY ONE and checked and double-triple-checked my work to make sure I am dropping in to matching folders... and matching files updated. But I always fall flat on my face.

    I do it, says I am running up-to-date version of 1.2.0 as if the one I am downloading is not correct. Had someone check my work previously and was told I installed the 1.2.0 files. How the heck could this be happening? What am I missing here?

    I have always made sure to check that the file I downloaded from here is the one I am using. Please help... I mean its not rocket science, but I am totally missing SOMETHING. I even went as far as following one prompt that said to delete some sort of install lock file.
  2. MistyMeanor

    MistyMeanor Active Member

    Do I need to UNCHECK download upgrade only??
  3. Shelley

    Shelley Well-Known Member

    I've always had that on checked when I've upgraded and upgraded fine. Having that checked shouldn't be a problem.
  4. MistyMeanor

    MistyMeanor Active Member

    Thanks @Shelley ... I mean the manual said if it says you are "current" when you are not, that it's because you didn't move the files correctly... but I am moving all of them under the upgrade folder their matching FTP folder and files??
  5. oman

    oman Well-Known Member

    When you are upgrading, you should check the download upgrade package, as it removes the files that aren't necessary for the upgrade to another version and that shouldn't be overwritten.

    You can uncheck it if you are doing a new installation.
  6. Shelley

    Shelley Well-Known Member

    Yeah that should be fine.

    I've done this before but i have a test installation which was upgraded and I tried to upgrade that when i was meant to upgrade my live site and was baffled why it wasn't upgrading (mistake on my part) could this be the case if you have a test installation on the same server?
  7. Chris D

    Chris D XenForo Developer Staff Member

    Sorry to be blunt but the issue is almost certainly an issue with uploading to the FTP.

    More than likely uploading to the wrong folder.

    Can you talk us through step by step exactly what you're doing and sometimes screenshots might be useful.

    The good news is, once you've done this you'll have no problem doing it again and again.
    Shelley likes this.

Share This Page