Fixed Admins not being listed in notable members: what am I doing wrong?

djbaxter

Well-known member
I have Moderators, a special group called "Local Search Experts", and a Most Messages group all displaying as Notable members on a forum.

I want to have Administrators also displayed but for the life of me I can't seem to get that to work.

Here are my current settings (I have tried various combinations previously that didn't work: this doesn't work either):

197399
197400
197401
197402
197403


Nothing is displayed:

197404


Any suggestions? Similar configurations work for the other groups. They just don't seem to work for Admins.
 

djbaxter

Well-known member
Not sure what happened to this post. I received a notification saying:

Brogan replied to a thread you are watching at XenForo community.
XF 2.0 - Admins not being listed in notable members: what am I doing wrong?
Which page of the ACP are those screenshots from?

There are some non-standard terms and fields, so I suspect a third party add-on is involved.
It's just the configuration page for notable members/member statistics:

197426

No third party add-ons for this but there is one non-standard group (Local Search Experts) and that and the other active stats groups are working:

197427

It's just the Administrators group that is missing.
 

Brogan

XenForo moderator
Staff member
If your user groups are set up correctly, the primary user group should be Registered and the secondary should be Administrative.
 

djbaxter

Well-known member
Yes. This was the first forum I migrated from vBulletin. But everything else is working and Moderators are set up the same way:

197429
 

Brogan

XenForo moderator
Staff member
This looks like a bug so I'll move the thread.

It works when sorting by Messages, Descending , but not Username, Descending.
 

Jeremy P

Well-known member
I recently encountered a similar problem. Unchecking the 'Show value' option fixed it for me. I had meant to report this but got side-tracked.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue. It has now been resolved and we are aiming to include it in a future XF release (2.1.1).

Change log:
Only apply the "Show value" option to member stats if the sort order is numeric (by default, if the sort order is not "username").
Any changes made as a result of this issue being resolved may not be rolled out here until later.
 
Top