1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Upgrading page blank.

Discussion in 'Installation, Upgrade, and Import Support' started by MatthewM, Aug 12, 2014.

  1. MatthewM

    MatthewM Member

    I am currently upgrading my forums to 1.3.5, however upon uploading the forum files for 1.3.5 from the upgrade package, and the forums displaying the "The board is currently being upgraded. Please check back later." message, upon going to /install (which, as usual, subsequently redirects to /install/index.php?upgrade/) I get a blank page.

    Edit: The log-in page does display first, however upon logging in, the page goes blank.

    Any thoughts would be greatly appreciated,
    Last edited: Aug 12, 2014
  2. Mike

    Mike XenForo Developer Staff Member

    What are you upgrading from? I would normally try reuploading the files. It's possible there was an error during the first upload.
  3. MatthewM

    MatthewM Member

    Thanks for the rapid reply.

    I have tried multiple uploads, however I will try again, just in case! I am upgrading from 1.3.1.

    Edit: unfortunately, the reupload did not fix the issue.
    Last edited: Aug 12, 2014
  4. Mike

    Mike XenForo Developer Staff Member

    I don't see an obvious reason for that to happen, especially if the login page is displaying. Try adding this to your library/config.php file:
    ini_set('display_errors', true);
    There may be a suppressed error.

    Otherwise, if you submit a ticket with admin and FTP login details, one of the staff can look into it. (However, please do note that it's now 11:45 PM in the UK where most of us are based.)
  5. MatthewM

    MatthewM Member

    I checked in my PHP Logging file, and I have several errors, the latest of which are:

    [12-Aug-2014 22:26:58 UTC] PHP Warning: Unterminated comment starting line 129 in /var/zpanel/hostdata/seedofandromeda/public_html/seedofandromeda_com/community/library/XenForo/Application.php on line 129
    [12-Aug-2014 22:26:58 UTC] PHP Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /var/zpanel/hostdata/seedofandromeda/public_html/seedofandromeda_com/community/library/XenForo/Application.php on line 130

    However I seem to have gotten no errors from the latest attempt to access the page.

    If I submit a ticket, I will make sure it is tomorrow, I have to be up early in the morning, so can't stay up too long myself.
  6. Mike

    Mike XenForo Developer Staff Member

    I suspect those error were from when you were in the middle of the upload. They wouldn't have allowed the login form to be displayed.
  7. MatthewM

    MatthewM Member

    That makes sense. I am trying one more upload for want of a better thing to do to work towards solving the issue, but I fear this is a problem not easily rectified. I will likely have to return the forums back to their previous state, and try again tomorrow should this attempt fail.

    Thanks for your help, especially at this late hour!
  8. Shelley

    Shelley Well-Known Member

    have you tried http://www.yoursite.com/admin.php

    And then running the install from there?
  9. MatthewM

    MatthewM Member

    The control panel only redirects to /install.php during upgrade, so it still results in the same problem.

    Thanks for the help, however Shelley!

Share This Page