XF 2.1 Upgrade to 2.1.9, now I get file check errors

cwe

Active member
Finally got around to upgrading my forum from XF 2.1.5 or so to 2.1.9. Auto-upgrade didn't work, so I had to do it manually. I logged in to XF customer area, downloaded upgrade package, unzipped it, uploaded files to the server, visited /install folder and clicked button to upgrade. ACP says I'm now running 2.1.9, but file health check now claims 585 files have unexpected results. I've re-uploaded all 585 files that it complained about, but running file check again, I get the same error on the same 585 files. How can I fix this?.
 

Brogan

XenForo moderator
Staff member
In general, the auto upgrade function should work so you may want to get your host to look at why it isn't and resolve it.

It sounds like there are issues with uploading the files, or some sort of underlying server issue.
You will have to upload them again if there are still file issues.

I don't know which FTP program you are using but try WinSCP.

If you have cPanel then the File Manager is by far the best way - upload the zip archive in its entirety and extract it directly on the server.
 

cwe

Active member
I tried the auto upgrade and couldn't get it to work. I've got a dedicated server and can get my server guy to configure it however it needs to be, but it's largely on me to figure out what needs to be changed and I don't have a clue, so I tried to do the update manually.

I used WinSCP to upload the files. I can confirm they were uploaded. I have no idea why XF thinks they aren't right.
 
Top