1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Upgrade to 1.5

Discussion in 'Installation, Upgrade, and Import Support' started by silence, Aug 19, 2015.

  1. silence

    silence Well-Known Member

    Code:
    Failed to get controller response and reroute to error handler (XenForo_ControllerPublic_Post::action)
    An exception occurred: Undefined index: use_tfa in /home/fdsa/public_html/xenforo/library/XenForo/Visitor.php on line 678
    
    XenForo_Application::handlePhpError() in XenForo/Visitor.php at line 678
    XenForo_Visitor->offsetGet() in XenForo/ControllerPublic/Abstract.php at line 269
    XenForo_ControllerPublic_Abstract->_assertTfaRequirement() in XenForo/ControllerPublic/Abstract.php at line 25
    XenForo_ControllerPublic_Abstract->_preDispatchType() in XenForo/Controller.php at line 310
    XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/fdsa/public_html/xenforo/index.php at line 13
    All files have been uploaded so I'm confused as to whats wrong.
     
  2. silence

    silence Well-Known Member

    I can't login to the admin panel either:

    Code:
    {"error":"Undefined index: use_tfa","traceHtml":"\t<li><b class=\"function\">XenForo_Application::handlePhpError
    ()<\/b> <span class=\"shade\">in<\/span> <b class=\"file\">XenForo\/ControllerHelper\/Login.php<\/b>
    <span class=\"shade\">at line<\/span> <b class=\"line\">14<\/b><\/li>\n\t<li><b class=\"function\">XenForo_ControllerHelper_Login-
    &gt;userTfaConfirmationRequired()<\/b> <span class=\"shade\">in<\/span> <b class=\"file\">XenForo\/ControllerAdmin
    \/Login.php<\/b> <span class=\"shade\">at line<\/span> <b class=\"line\">132<\/b><\/li>\n\t<li><b class
    =\"function\">XenForo_ControllerAdmin_Login-&gt;actionLogin()<\/b> <span class=\"shade\">in<\/span>
    <b class=\"file\">XenForo\/FrontController.php<\/b> <span class=\"shade\">at line<\/span> <b class=\"line
    \">347<\/b><\/li>\n\t<li><b class=\"function\">XenForo_FrontController-&gt;dispatch()<\/b> <span class
    =\"shade\">in<\/span> <b class=\"file\">XenForo\/FrontController.php<\/b> <span class=\"shade\">at line
    <\/span> <b class=\"line\">134<\/b><\/li>\n\t<li><b class=\"function\">XenForo_FrontController-&gt;run
    ()<\/b> <span class=\"shade\">in<\/span> <b class=\"file\">\/home\/fdsa\/public_html\/xenforo\/admin
    .php<\/b> <span class=\"shade\">at line<\/span> <b class=\"line\">13<\/b><\/li>\n"}
     
  3. silence

    silence Well-Known Member

  4. Mike

    Mike XenForo Developer Staff Member

    Just to confirm to anyone seeing this, you need to complete the upgrade by going directly to the upgrade URL (which is the recommended approach: Upgrades | XenForo).
     
    silence and Lemminator like this.

Share This Page