• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Upgrade to 1.4 failed

#1
I received these messages when trying upgrade from 1.3.4 to 1.3.5 or 1.4.0

Are you sure you want to upgrade? [y/n] y
Rebuilding / importing data...
Rebuilding... Phrases .
An exception occurred: Got unexpected, non-string/non-array segments for compilation. in XenForo/Template/Compiler.php on line 367
#0 XenForo/Model/Template.php(1611): XenForo_Template_Compiler->compileParsed(false, 'footer', 10, 2)
#1 XenForo/Model/Template.php(1378): XenForo_Model_Template->compileAndInsertParsedTemplate(670, false, 'footer', 10)
#2 XenForo/Model/Template.php(1328): XenForo_Model_Template->compileTemplateInStyleTree(Array)
#3 XenForo/Model/Template.php(1267): XenForo_Model_Template->compileNamedTemplateInStyleTree('footer', 10)
#4 XenForo/Deferred/Template.php(36): XenForo_Model_Template->compileAllTemplates(7.5623788833618, 0, 0)
#5 XenForo/Deferred/Atomic.php(66): XenForo_Deferred_Template->execute(Array, Array, 7.9999330043793, 'Rebuilding... T...')
#6 XenForo/Model/Deferred.php(256): XenForo_Deferred_Atomic->execute(Array, Array, 8, 'Rebuilding... T...')
#7 XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 8, 'Rebuilding... T...', false)
#8 XenForo/Model/Deferred.php(316): XenForo_Model_Deferred->_runInternal(Array, NULL, 'Rebuilding... T...', false)
#9 XenForo/Install/run-upgrade.php(170): XenForo_Model_Deferred->runByUniqueKey('installUpgradeR...', NULL, 'Rebuilding... T...')
#10 {main}
 
#2
Tried many times & received other message:

Server Error
unserialize(): Error at offset 176 of 13061 bytes

  1. XenForo_Application::handlePhpError()
  2. unserialize() in XenForo/Model/Template.php at line 1362
  3. XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1328
  4. XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1267
  5. XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
  6. XenForo_Deferred_Template->execute() in XenForo/Deferred/Atomic.php at line 66
  7. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 256
  8. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 390
  9. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 316
  10. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
  11. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
  12. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
  13. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  14. XenForo_FrontController->run() in /home/tinhyeu/domains/tinhyeu.com/public_html/install/index.php at line 18
 

Mike

XenForo developer
Staff member
#3
Things like this usually indicate there is some sort of corrupt data in the DB -- it would often indicate that the DB was modified directly.

If you submit a ticket with ACP access details and phpMyAdmin information I can have a look. It's worth noting that customized templates may need to be removed to get past this.
 
#4
Things like this usually indicate there is some sort of corrupt data in the DB -- it would often indicate that the DB was modified directly.

If you submit a ticket with ACP access details and phpMyAdmin information I can have a look. It's worth noting that customized templates may need to be removed to get past this.

I submitted the ticket.