1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade to 1.1.4 not being recognized

Discussion in 'Installation, Upgrade, and Import Support' started by Backgen, Mar 27, 2013.

  1. Backgen

    Backgen New Member

    Hello!

    Having some trouble upgrading to 1.1.4 from 1.1.3

    I'm using filezilla to upload everything to the FTP. I've just been selecting all the files/folders inside the "upload" folder from the download and dragging them to the xenforo folder in the FTP. I made sure that existing files were overwritten.

    However when i then point my browser to /install - i'm getting the "No upgrade available" page - and it's telling me that "You are already running the current version (1.1.3). To do a fresh install, click here."

    From the manual i realize that this might be an issue with files not being overwritten properly, so i've repeated the upload process a few times but still always the same result.

    Is there something i've missed? Anyone had this problem as well?

    Thanks!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds as if you are uploading the 1.1.3 files.

    Do a fresh download from the customer area and try again.
     
  3. Backgen

    Backgen New Member

    Ok just did it - still the same thing.

    the download file is named "xenforo_1.1.4_270A09..." so should be the correct version right?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Make sure you are uploading the files to the correct location.
     
  5. Backgen

    Backgen New Member

    Yup, i'm sure
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    The upgrade script is not seeing the new files so it can really only be one of those three things: wrong files, not uploaded to the correct location, not overwriting the existing files.
     
    lazy llama and Andrej like this.
  7. Reeve of Shinra

    Reeve of Shinra Well-Known Member

    I had the same issue... there's two check icons to check off near the middle right side in Filezilla
    • Synchronize Folders (so as you move through one side, it will move through the other assuming its the same folder structure)
    • Compare ( will compare contents and only show you what is different between the two).
    Upload the entire folder. Right Click Upload
    Go folder by folder until you dont see any more discrepencies

    Then try the update again.

    I hate FTP for this reason.
     
  8. SchmitzIT

    SchmitzIT Well-Known Member

    Try and make sure the folder you drag over contains the library folder. MAke sure you drag it over to the equivalent on the FTP server.

    So if on your local machine, you move into "upload", which contains "library", make sure you upload that to, say, "httpdocs", which also contains library.

    Don't set anything, but instead wait for the filezilla prompt to tell you files exist already, and then select to overwrite.
     
  9. kefallon

    kefallon Member

    Did exactly the same last night :oops: drag the folders onto forum directory not individual folders or you end up creating styles-styles etc.
    Did have to mod permissions, what should each directory be set too?
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  11. Steqheu

    Steqheu Member

    For anyone that happens to stumble on this thread - you may have done what I did.

    Instead of transferring the upgrade files to www.xxxxx.com/forums, I put them in www.xxxxx.com/forums/upload

    The upload folder (that you get as part of the 1.1.4 or 1.1.5 etc. download) makes this a little confusing. But the contents of the /upload folder in the upgrade download are supposed to be overwritten directly to the root of your forum - not the upload directory as one may assume.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member


    The instructions explicitly state that: http://xenforo.com/help/upgrades/
     
    Steqheu likes this.
  13. Steqheu

    Steqheu Member

    Yes, it was a mistake on my part of course.

    I just wanted to post so that others might realize the same lame mistake.
     

Share This Page