• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Upgrade System warning

Bionic Rooster

Well-known member
#1
When ever I upgrade I get this error
Upgrade System
The following warnings were detected when verifying that your server can run XenForo:

  • Your server is running an outdated and unsupported version of PHP (5.2.17). If possible, you should upgrade to PHP 5.4 or 5.5.
These may affect the proper execution of XenForo at times and should be resolved if possible.

Click the button below to begin the upgrade to 1.3.2.

Yet I have installed



PHP 5.4 (Single php.ini)
Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini

Any ideas why this error keeps coming up?
Thanks,
 

Jeremy P

Well-known member
#2
Putting a page in the XenForo directory with:
PHP:
<?php phpinfo();
..and accessing it returns PHP 5.4 as the version? The check uses an internal constant in PHP so it's pretty unlikely it'd be erroneous. I'd suspect server misconfiguration.
 

whynot

Well-known member
#6
Perhaps some of your folders are using 5.2 and the rest 5.4
Most probably you can find it out in your site's control panel