XF 2.1 Upgrade from 2.1.5 to 2.1.11

dtrumbower

Member
Now that 2.2 is released, it looks the only way to update my site to 2.1.11 is manually. When I do copy the update files to my system and run install, it says a newer version is available but doesn't do the 2.1.11 install.

What am I missing?
 
Last edited:

Brogan

XenForo moderator
Staff member
Can you screenshot what you see after navigating to /install?

There's nothing which would stop upgrading to versions other than the latest release.
 

dtrumbower

Member
V2.1.5 is current. I'm upgrading a copy of my product on my local machine. I will play around with a few other version and see if that helps at all.
Thank you for your time.
 

Brogan

XenForo moderator
Staff member
That message typically only displays if older files are uploaded and the database is at a later version, so it doesn't make a lot of sense.

If the site was at 2.1.5 then uploading the 2.1.9 or 2.1.11 files should trigger the standard upgrade script and it should be able to run without issue.
 

Mike

XenForo developer
Staff member
Did you upload the 2.2 files at some point? If so, then you have some remnant files from that (files that don't exist in 2.1). Specifically, this is a 2.2-related upgrade script (that would try to run if we didn't block it with that message).

You could delete the contents of the src/XF/Install/Upgrade directory and replace them with the expected contents from the correct 2.1 version and that would clear the message. (There may be other 2.2 files present though they shouldn't generally cause errors if they're not called though there could still be a mix of unexpected files in some cases.)
 
Top