1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Upgrade from 1.0.x to 1.1.2 fails

Discussion in 'Installation, Upgrade, and Import Support' started by Reeve of Shinra, Apr 6, 2012.

  1. Reeve of Shinra

    Reeve of Shinra Well-Known Member

    I downloaded the full package for 1.1.2, uploaded the files to my server, went to do the upgrade and WHAM at the final rebuilds. Not sure what this means or how to fix it. I reverted my database as I couldn't get into the site (error further below) and the admin panel said that there was an upgrade in progress effectively locking me out.

    Incidentally, I tried it a second time with no further luck.

    I had an issue on an earlier upgrade but left it alone. I am not sure I just compounded the problem. I was too busy to find a fix for it then.

    -----------------------------------------------------------------



    Mysqli statement execute error : Duplicate entry '1-Index' for key 2
    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in XenForo/Model/Phrase.php at line 948
    1. XenForo_Model_Phrase->insertPhraseMapForLanguages() in XenForo/CacheRebuilder/Phrase.php at line 38
    1. XenForo_CacheRebuilder_Phrase->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    1. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Upgrade.php at line 232
    1. XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/FrontController.php at line 310
    1. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    1. XenForo_FrontController->run() in /home/shinra/public_html/xen/install/index.php at line 18

    Pasted from <http://shinraonline.com/xen/install/index.php?upgrade/rebuild>




    Fatal error: Call to undefined method XenForo_Template_Helper_Core::avatarHtml() in /home/shinra/public_html/xen/library/XenForo/Template/Abstract.php(265) : eval()'d code on line 1168

    Pasted from <http://shinraonline.com/xen/>
     
  2. Reeve of Shinra

    Reeve of Shinra Well-Known Member

    Okay, restored the backup but I'm still getting this error message that the upgrade is in progress -- is this automatic if you have the 1.1.2 files up?
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    If you have an old database with new files then that message will show.

    That's a file problem. Upload the files again.

    For some reason that phrase title is capitalized (Index instead of index). Find that phrase in your Admin CP and change the title to all lowercase. Or revert the phrase. That should allow the upgrade script to run.
     
  4. Reeve of Shinra

    Reeve of Shinra Well-Known Member

    Thank you ... I had to go into phpmyadmin and delete those phrases because I couldn't get into the admincp. Hopefully I didn't break too much.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It should be safe. The upgrade script will restore any missing phrases.
     

Share This Page