• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Unregistered User have no permission for viewing forum

Lemminator

Well-known member
#1
Hi
I have the problem that unregistered users have no access to the forum. All user groups have Yes in the groups right stand for read, see etc. All user groups have Yes in the groups right stand for read, see etc..

Is there another shot I missed? or can it be a problem with the update of Xf1?
Bildschirmfoto 2017-11-22 um 16.49.05.png
 

Brogan

XenForo moderator
Staff member
#2
I have no problem viewing the landing page and forum index on your site, as a guest.

I can also access forums and threads.
 

Chris D

XenForo developer
Staff member
#3
I think this relates to an XF2 test site, which does prompt me to log in.

It's possible it could be a cache that hasn't been updated in some capacity but the best way to test that is to change one of those permissions, perhaps the "View" one, set it to Never, then Save. Then go back and set it to "Yes" again.

Does that fix the issue?
 

Lemminator

Well-known member
#4
I've changed the right one a lot, and I've put it back in full view, but unfortunately I can't do it.
the same problem is also when I access the test page with my iPhone.

where can I give you the login data?
 

Chris D

XenForo developer
Staff member
#6
Although we're not currently supporting XF2 with ticket support, if you submit a ticket then exceptionally we'll take a look. Please provide an Admin CP login in the first instance, though if we cannot troubleshoot it that way we may need database and FTP access.